1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Playback fails with Plex client

Support for the native Plex Client on any platform
User avatar
amet
Team MrMC
Posts: 2757
Joined: 26 Oct 2015, 16:59
Location: Dubai/Novi Sad

Re: Playback fails with Plex client

Post by amet » 13 Mar 2019, 18:32

this usually happens when the router has specific settings enabled, DNS rebinding.

https://support.plex.tv/articles/206225 ... nnections/

I am not sure why it works on plex app and not on MrMC.... try manually logging in using user/pass in Settings->Services -> Plex and see if that helps.

you sure that transcoding is not enabled in Settings->Services -> Plex?

Gingus
Posts: 9
Joined: 22 Jan 2019, 18:23

Re: Playback fails with Plex client

Post by Gingus » 14 Mar 2019, 17:12

Hi

No, Transcoding is disabled in settings.

I tried manually logging into the Plex service...no change.

I have also tried deleting mrmc data, uninstalling, reinstalling etc etc...nothing has made any difference. The only way of getting movies to play is to either just use the Plex server as a UPnP Source, or create a separate library in MrMC referencing back to the files on the Nas. Obviously this isn't ideal as I am then maintaining 2 libraries!


Thanks for the article link, I will have to read through and check my router settings.

Peter

Gingus
Posts: 9
Joined: 22 Jan 2019, 18:23

Re: Playback fails with Plex client

Post by Gingus » 15 Mar 2019, 17:09

amet wrote:
13 Mar 2019, 18:32
this usually happens when the router has specific settings enabled, DNS rebinding.

https://support.plex.tv/articles/206225 ... nnections/

I am not sure why it works on plex app and not on MrMC.... try manually logging in using user/pass in Settings->Services -> Plex and see if that helps.

you sure that transcoding is not enabled in Settings->Services -> Plex?


Is the DNS rebinding issue not more applicable to the IP address of the device rather than the apps that device is running?

Just as an experiment, I tried a similar exercise on my Android phone connected over wifi on my home network. ie ran a stream from the Android Plex App, which ran fine, and showed as a local stream. Then installed MrMc on the same device, signed into the plex client and tried to run a movie through this. SD movies played fine, but they showed as a remote stream on the Plex Server dashboard. Higher bitrate 1080 and 4k movies failed to play.

So this is the exact same behaviour as on the Nvidia Shield TV.

Any further ideas what else may be causing mrmc to be seen as a remote device?

User avatar
amet
Team MrMC
Posts: 2757
Joined: 26 Oct 2015, 16:59
Location: Dubai/Novi Sad

Re: Playback fails with Plex client

Post by amet » 15 Mar 2019, 18:16

DNS rebinding translates “https://86-146-209-180.85b94083e55d4e5b ... lex.direct” to your local address, that’s how plex has set it up. I can’t comment on why or how their app does it ...

I’ll have a look around to see if there is a better way to check if the server is on a local network, but plex api is badly documented :(

Gingus
Posts: 9
Joined: 22 Jan 2019, 18:23

Re: Playback fails with Plex client

Post by Gingus » 21 May 2019, 08:52

Hi

Just wanted to add here, that since the last update, This issue has gone away and playback with Plex client is now working again as it should be.

If this was a fix in the release, then thanks very much!


Thanks
Peter

Post Reply