1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Update library not working

Any issues that are tvOS specific
PeMaGonGo
Posts: 3
Joined: 25 Jun 2019, 15:50

Re: Update library not working

Post by PeMaGonGo » 01 Jul 2019, 21:16

Hi everyone,
Unfortunately I have quite the same problem.
When I want to add a movie Smb Share nothing is found. I have to enable libdsm2 by the way.
I’m able to browse the source and when I enter a Folder and after that “search for new content” it finds it! But not alone. Of course recursive search and folder name is movie title is enabled.
It works for tv shows on the same smb share by the way.
Reinstalling didn’t help.
I have tvOS 13 installed but the problem also appeared on the latest stable tvOS.

Thanks and greetings

PeMaGonGo

Debuglog
https://pastebin.com/V9mJPpq3

PeMaGonGo
Posts: 3
Joined: 25 Jun 2019, 15:50

Re: Update library not working

Post by PeMaGonGo » 07 Jul 2019, 10:37

Hi,
I made some more tests.
Tried to reset the Apple TV 4K. Same result.
Tried on an older Apple TV 4 HD with formerly working MrMc. Stoped working!
I think it has to do with the share.
The movies are on a windows 10 share with the latest pre 1903 update. Yet not able to install 1903 update.

As mentioned before, I am able to browse through the movies and mrmc is able to get the infos after I select a movie or Movie Set.

Hope it helps find the bug.

Greetings
PeMaGonGo

User avatar
davilla
Team MrMC
Posts: 4150
Joined: 26 Oct 2015, 17:01

Re: Update library not working

Post by davilla » 07 Jul 2019, 15:44

Your windows 10 might not know about smb1 anymore. Libdsm uses smb1 protocol.
Switch to libsmb2 client in MrMC.

PeMaGonGo
Posts: 3
Joined: 25 Jun 2019, 15:50

Re: Update library not working

Post by PeMaGonGo » 08 Jul 2019, 11:57

I were able to locate the false configuration.
Here my background: I use 2 shares locating my content. One older NAS only able to use smb1 and the win10 with smb1 and smb2 enabled.
With your hint in mind (I misspelled before, I meant lbsmb2) I tried around with the smb-client with the following results:
Default config : Nas playing(browsing) & scrapping works, win10 nothing working
Libdsm enabled: nas and win10 playing, but no scrapping
Libdsm & libsmb2 enabled: nas & win10 playing, no scrapping
Libsmb2 enabled: nas not playing nor scrapping, win10 playing & scrapping

So my workaround looks like using libsmb2 to scrap new content and switch to libdsm to play all my content.

What I would aspect is being able to play and scrap content available over smb1 and smb2, without switching.
I hope it helps.

Greetings
PeMaGonGo

Post Reply