1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Testing MrMC 3.8.1 for Google Play

Google Play Store and App Store beta test feedback
Locked
semperfixd
Posts: 34
Joined: 09 May 2018, 18:25

Re: Testing MrMC 3.8.0 for Google Play

Post by semperfixd » 27 Feb 2019, 15:14

koying wrote:
27 Feb 2019, 15:03
cosmoxl wrote:
27 Feb 2019, 14:18
Can you explain more about the new advanced timing setting under AMC Surface?
That is an hybrid way to time frames between MrMC and Android, that is already being used on Shield but that was not available on the other devices.

As I noticed it solves issues with interlaced playback on AFTV stick 3 as well, I extended it to all devices, but made in an option because I remember some other devices had issue with it.
The file that I pushed "NCOP 1 (without credits)" still drops frames. Plays fine on Kodi

cosmoxl
Posts: 1549
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.8.0 for Google Play

Post by cosmoxl » 27 Feb 2019, 15:16

koying wrote:
27 Feb 2019, 15:03
cosmoxl wrote:
27 Feb 2019, 14:18
Can you explain more about the new advanced timing setting under AMC Surface?
That is an hybrid way to time frames between MrMC and Android, that is already being used on Shield but that was not available on the other devices.

As I noticed it solves issues with interlaced playback on AFTV stick 3 as well, I extended it to all devices, but made in an option because I remember some other devices had issue with it.
OK thanks.

I just finished a show and as MrMC went back to its home screen it crashed my Shield, forcing me to have to unplug it. I think there are others reporting this too. I went back to look at the old log but nothing's there re the crash. The last line it has is

Code: Select all

09:06:53.041 T:187530949872   DEBUG: CDVDVideoCodecAndroidMediaCodec::GetOutputPicture index(0), pts(3669677210.000000)
09:06:53.041 T:187530949872   DEBUG: CDVDVideoCodecAndroidMediaCodec::Decode, rtn(4), m_demux.size(0)
�������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������

hieyemtim
Posts: 43
Joined: 01 Nov 2018, 23:47

Re: Testing MrMC 3.8.0 for Google Play

Post by hieyemtim » 27 Feb 2019, 16:23

hieyemtim wrote:
27 Feb 2019, 00:34
hieyemtim wrote:
18 Feb 2019, 23:02
hieyemtim wrote:
17 Feb 2019, 20:05


With February 14th build I’m having this exact same problem with mapping issues on this file. It never worked for me. Also, If I play any atoms file I have video and audio stutter for the first 20 seconds of each file. It has improved over the last few builds. Now my receiver doesn’t go back and forth from stereo to atmos to stereo to atmos. Thanks so much for improving the code. You’re almost there. So close.
2019-02-17 release. Atmos is much better. Only cuts out once. So so close. This file still has mapping issues and plays the center channel audio in the rear after about 10 seconds. I still wish audio on atoms files didn’t cut out once during each file. It’s a loud clipping (click) noise so I still can’t use it as my main player quite yet but it’s so much better. I do notice that remux 4K videos studder for a moment at the beginning of the file and that is usually where the atoms files have a loud audio (click) for a moment. DTSX files work without any audio clipping but I still notice the video shudder at the beginning. Love the new interface. So clean and crisp! Thanks for working so hard on this. So so close!
2019-02-23 release. Even better!! Almost perfect. Atmo now only cuts out for a moment after playing a file, with no audio click noise anymore, on all Atmos files. Just an audio drop for a moment. Some DTSX files have a tiny click sound after playing a file but no audio drop. It’s at the same moment as the audio drop out on atoms files. A second after playing the file. The file Nature’s Fury, Dolby Atmos Leaf and Conductor demos still have channel mapping issues, however if you rewind the video and play, the mapping issues are solved. I’m currently trying more demos and it seems all the atoms demo files have these mapping issues. Thanks so much for your hard work It’s almost perfect
2-26-5784896 build still showing these issues for me. I’m noticing files in any audio format DTS HD Master, atmos etc, sometimes open in Stereo. A rewind or restart to the file brings it to its correct audio format. All these files work perfectly with SPMC. Thank you for digging into this and all your hard work
Last edited by hieyemtim on 27 Feb 2019, 17:00, edited 3 times in total.

User avatar
koying
Team MrMC
Posts: 389
Joined: 20 Mar 2016, 17:49

Re: Testing MrMC 3.8.0 for Google Play

Post by koying » 27 Feb 2019, 16:47

cosmoxl wrote:
27 Feb 2019, 15:16
I just finished a show and as MrMC went back to its home screen it crashed my Shield, forcing me to have to unplug it. I think there are others reporting this too. I went back to look at the old log but nothing's there re the crash. The last line it has is
Is it reproducible? I have some doubts MrMC could crash the shield all by itself.

hieyemtim
Posts: 43
Joined: 01 Nov 2018, 23:47

Re: Testing MrMC 3.8.0 for Google Play

Post by hieyemtim » 27 Feb 2019, 17:33

hieyemtim wrote:
27 Feb 2019, 16:23
hieyemtim wrote:
27 Feb 2019, 00:34
hieyemtim wrote:
18 Feb 2019, 23:02


2019-02-17 release. Atmos is much better. Only cuts out once. So so close. This file still has mapping issues and plays the center channel audio in the rear after about 10 seconds. I still wish audio on atoms files didn’t cut out once during each file. It’s a loud clipping (click) noise so I still can’t use it as my main player quite yet but it’s so much better. I do notice that remux 4K videos studder for a moment at the beginning of the file and that is usually where the atoms files have a loud audio (click) for a moment. DTSX files work without any audio clipping but I still notice the video shudder at the beginning. Love the new interface. So clean and crisp! Thanks for working so hard on this. So so close!
2019-02-23 release. Even better!! Almost perfect. Atmo now only cuts out for a moment after playing a file, with no audio click noise anymore, on all Atmos files. Just an audio drop for a moment. Some DTSX files have a tiny click sound after playing a file but no audio drop. It’s at the same moment as the audio drop out on atoms files. A second after playing the file. The file Nature’s Fury, Dolby Atmos Leaf and Conductor demos still have channel mapping issues, however if you rewind the video and play, the mapping issues are solved. I’m currently trying more demos and it seems all the atoms demo files have these mapping issues. Thanks so much for your hard work It’s almost perfect
2-26-5784896 build still showing these issues for me. I’m noticing files in any audio format DTS HD Master, atmos etc, sometimes open in Stereo. A rewind or restart to the file brings it to its correct audio format. All these files work perfectly with SPMC. Thank you for digging into this and all your hard work
2-26-5784896 Build update. Some files will only play in stereo until I quit MRMC and restart it. Then they usually work in atmos, DTS HD Master etc. All these files always work with SPMC. Thanks!

User avatar
koying
Team MrMC
Posts: 389
Joined: 20 Mar 2016, 17:49

Re: Testing MrMC 3.8.0 for Google Play

Post by koying » 27 Feb 2019, 18:04

hieyemtim wrote:
27 Feb 2019, 17:33
2-26-5784896 Build update. Some files will only play in stereo until I quit MRMC and restart it. Then they usually work in atmos, DTS HD Master etc. All these files always work with SPMC. Thanks!
debuglog , please

hieyemtim
Posts: 43
Joined: 01 Nov 2018, 23:47

Re: Testing MrMC 3.8.0 for Google Play

Post by hieyemtim » 27 Feb 2019, 18:23

koying wrote:
27 Feb 2019, 18:04
hieyemtim wrote:
27 Feb 2019, 17:33
2-26-5784896 Build update. Some files will only play in stereo until I quit MRMC and restart it. Then they usually work in atmos, DTS HD Master etc. All these files always work with SPMC. Thanks!
debuglog , please

Hi Koying. I’m receiving the error “Web server failed to start” when I try to enable Allow HTTP. Do you have any advice? I do have the paid full version. I’ve restarted the program and still get the error. Thanks!

User avatar
koying
Team MrMC
Posts: 389
Joined: 20 Mar 2016, 17:49

Re: Testing MrMC 3.8.0 for Google Play

Post by koying » 27 Feb 2019, 18:30

Maybe SPMC or Kodi running in the background?

hieyemtim
Posts: 43
Joined: 01 Nov 2018, 23:47

Re: Testing MrMC 3.8.0 for Google Play

Post by hieyemtim » 27 Feb 2019, 18:34

Yes. Thank you. SPMC was in the background. I’ll close it. I uninstalled MRMC and reinstalled it. Should have rebooted first. That would have solved it. I’m going through setup now and will enable web and get you that debug. Thanks for all your help!

hieyemtim
Posts: 43
Joined: 01 Nov 2018, 23:47

Re: Testing MrMC 3.8.0 for Google Play

Post by hieyemtim » 27 Feb 2019, 19:08

hieyemtim wrote:
27 Feb 2019, 18:23
koying wrote:
27 Feb 2019, 18:04
hieyemtim wrote:
27 Feb 2019, 17:33
2-26-5784896 Build update. Some files will only play in stereo until I quit MRMC and restart it. Then they usually work in atmos, DTS HD Master etc. All these files always work with SPMC. Thanks!
debuglog , please

Hi Koying. I’m receiving the error “Web server failed to start” when I try to enable Allow HTTP. Do you have any advice? I do have the paid full version. I’ve restarted the program and still get the error. Thanks!
Here you go Koying. Thank you for all your amazing coding magic
Last edited by hieyemtim on 28 Feb 2019, 17:11, edited 1 time in total.

Locked