1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Suddenly stuck on "migrating database" on boot

Support for any MySQL database connection issues
Post Reply
Posts: 129
Joined: 18 Nov 2015, 11:30

Suddenly stuck on "migrating database" on boot

Post by Looxoor » 20 Mar 2017, 10:24


I've had a mysql database library running flawlessly since before MrMC and upgraded all clients to MrMC v 3+ (and therefore also migrated dB to Kodi 17) and everything still worked.

Then I moved everything to a new server, changed ip in the clients, all still good.

However, this weekend I thought I'd secure the new server a bit so I played with iptables and fail2ban.
Now I get the "migrating database" screen on boot and no chance to read any logs or do anything at all.

I'm guessing that the server refuses connection to non localhost attempts even though I can't find any entries
in any logs?

Here's my iptables -S with fail2ban stopped.

(I'm on Raspbian jessie on a Pi 3)

Code: Select all

-P INPUT ACCEPT                                                                                                          
-P FORWARD ACCEPT                                                                                                        
-P OUTPUT ACCEPT                                                                                                         
-A INPUT -i lo -j ACCEPT                                                                                                 
-A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT                                                            
-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT                                                                              
-A INPUT -p tcp -m multiport --dports 80,443 -j ACCEPT                                                                   
-A INPUT -j DROP                                                                                                         
-A INPUT -s -p tcp -m tcp --dport 3306 -m state --state NEW,ESTABLISHED -j ACCEPT                         
-A OUTPUT -p tcp -m tcp --sport 3306 -m state --state ESTABLISHED -j ACCEPT
Here's hoping some of you have a better grasp on these things as I'm pretty new on using Linux and doing this whole thing as a learning experience.

In my haste to post something I forgot why I bothered you with this information in the first place:

I think it would be very useful with a timeout for on-boot loading of mysql-database with a cancel-button which takes you to homescreen so you can edit settings and read logs etc.

I flushed the iptables and now it works so obviously I'd made some worthless shit in there.

I still think it'd be really useful though for troubleshooting with a timeout for unresponsiveness with a cancel-button and some kind of error message.

Over and out.

Post Reply