1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Media randomly hangs, then increases playback speed to "catch up"

Any issues that are Nvidia Shield TV specific
Post Reply
CallClear
Posts: 58
Joined: 29 Mar 2016, 21:29

Media randomly hangs, then increases playback speed to "catch up"

Post by CallClear » 11 Apr 2019, 22:51

Hi. I can't figure out any pattern to the behavior but when playing media through MRMC on my Shield, the screen will often hang as if paused...sometimes for less than a second and sometimes up to over a minute. Then it will suddenly speed up presumably to catch up to the timeline where it should be if it wouldn't have paused. Also, and this may not be related, but the audio occasionally starts making soft clicking and popping sounds. Typically if I just pause/unpause or skip, it goes away. Again, I can't figure out a pattern of why it happens...I just know it happens with all of my videos eventually.

I have some logs that capture when the issue occurs but the problem is that since I never know when it is going to happen, I have to just play things until it occurs and at that point the log file is too big for pastebin. But I can provide them if needed. I just need to know where to put them. Only thing I can see from them are a lot of "WARNING: ActiveAE - large audio sync error" messages. My version of MrMC is 3.8-0 Git:2019-03-02-6253bc1. Shield version is 8.0.0. Any help is appreciated!

User avatar
davilla
Team MrMC
Posts: 3987
Joined: 26 Oct 2015, 17:01

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by davilla » 12 Apr 2019, 01:01

use the webserver to pop up the OSD of codec info. Look at aq/vq, are they draining to zero ?

CallClear
Posts: 58
Joined: 29 Mar 2016, 21:29

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by CallClear » 12 Apr 2019, 01:40

When playing normally, aq hovers between 91 and 92%. vq maintains constant 99%. When the video freezes, aq drains to 0.

User avatar
davilla
Team MrMC
Posts: 3987
Joined: 26 Oct 2015, 17:01

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by davilla » 12 Apr 2019, 11:54

CallClear wrote:
12 Apr 2019, 01:40
When playing normally, aq hovers between 91 and 92%. vq maintains constant 99%. When the video freezes, aq drains to 0.
You are saying that video freezes and vq is still 99 percent ?

CallClear
Posts: 58
Joined: 29 Mar 2016, 21:29

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by CallClear » 12 Apr 2019, 13:47

Yes. Vq remains at 99%. Only aq drains down.

User avatar
davilla
Team MrMC
Posts: 3987
Joined: 26 Oct 2015, 17:01

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by davilla » 12 Apr 2019, 13:53

debuglog showing this issue, please.

CallClear
Posts: 58
Joined: 29 Mar 2016, 21:29

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by CallClear » 12 Apr 2019, 15:13

The files are too big for pastebin. Is there an email I can send compressed files? Or are you okay with only partial logs?


CallClear
Posts: 58
Joined: 29 Mar 2016, 21:29

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by CallClear » 12 Apr 2019, 16:02

Sent.

I noticed that I had Component Specific logging enabled for the video component and your debuglog instructions screenshot indicated it disabled. I'm not sure how it got enabled...maybe a long time ago I enabled it and forgot to disable it? I disabled it for a smaller log...but it still didn't fit in pastebin.

Log1 is a short pause around 14:53:30. Log2 is a really long pause around 08:05:06. Log3 is the file with component specific logging turned off...also a big pause.

Thanks for your help!

CallClear
Posts: 58
Joined: 29 Mar 2016, 21:29

Re: Media randomly hangs, then increases playback speed to "catch up"

Post by CallClear » 23 Apr 2019, 15:17

Hi. Is there any more information needed or suggestions on something I might try to fix this? It does seem like this issue is unique to my setup. This may just be coincidence...but it appears when it does freeze up for long periods of time, it is approx 15 seconds after playback is resumed from a pause.

Post Reply