Page 1 of 3

LiveTV issue

Posted: 08 May 2019, 22:00
by vrabac
With the version 3.8.1 I am having following issue:

Using PVR IPTV Simple Client and VDR VNSI Client.

- after starting mrmc and waiting to settle down I don't see TV Menu (but saw message from plugins about loading channels / epg etc), need to go for example to settings and back to see TV, then after some time the Radio Menu option also shows up.

- after zapping to some channel there is pause, probably this was taken from "Setting -> Video -> Playback -> Pause during refresh rate change". But for LiveTV there is no refresh rate change, and if you play it in "windowed screen " egg. not full screen, then there is for sure no refresh rate change, at least I don't see any when checking info of my TV setting (1080p at 50HZ).

- unable to go to full screen - when in "windowed screen" and zapping to another channel I am unable to click once more to go to full screen

- when on one channel I am unable to switch to another.

- web server does not show TV or Radio Menu

Debug log attached. I hope you can see in debug log all what I described above.

Re: LiveTV issue

Posted: 11 May 2019, 06:55
by Palmdale95
Hi there.

This sounds really strange. I am using a vdr with easyvdr 2.3 as backend and don’t have these issues. It takes some time to load the TV section but then it works.
From my side there is an other problem.
Als Clients I use one Apple TV 4K and one 4. on the 4K I have no Problems with displaying german TV from ARD and ZDF. On the 4 however there is just sound and no picture. It is just not starting. I don’t know where it’s comes from. Do you have any idea?

Greetings Markus

Re: LiveTV issue

Posted: 11 May 2019, 20:23
by vrabac
Well that also sounds strange, I guess you should open new Forum Topic, explain there your problem and put the debug log from Apple TV 4-Gen . And hope that there is something inside that debug log and that mrmc can help you there.

@mrmc developers do you see anything strange in my debug log related to list I posted in first thread?

Re: LiveTV issue

Posted: 11 May 2019, 20:28
by amet
vrabac wrote:
11 May 2019, 20:23
Well that also sounds strange, I guess you should open new Forum Topic, explain there your problem and put the debug log from Apple TV 4-Gen . And hope that there is something inside that debug log and that mrmc can help you there.

@mrmc developers do you see anything strange in my debug log related to list I posted in first thread?
Could you enable debug logging and upload a new debuglog please

Re: LiveTV issue

Posted: 11 May 2019, 21:03
by vrabac
@amet here we go

On zap to first channel, i see video in small window but paused, and after 5+ sec it start playing it. I clicked then again to make it full screen, nothing happens, also pressed few times no go, and if I press "Menu" button on Apple TV 4k remote, it goes out completely to tvos main menu, going back to mrmc and wait few sec I got picture in full screen, only it get played again after few seconds. By pressing menu again I am again back where it should and that is TV channel list. I hope this can be seen in log. If now i could try to capture whole thing with game capture card.

Re: LiveTV issue

Posted: 12 May 2019, 03:35
by amet
It’s still not a debuglog, we need debug logging enabled in settings

No need to capture it, I get it ... just need to have a real debuglog for @davilla to see what’s up with audio

Re: LiveTV issue

Posted: 12 May 2019, 05:43
by vrabac
I was sure that I did enabled debug but seems it was not.
Anyway here it is again password protected: mrmc

I did some randomization in log but not relevant paths (I hope).

On the beginning of the log there should be seen that zap to first channel in windowed state works after some seconds and then if I try to make full screen will not work, also zap to another channel did not work. Eventually after press of Menu remote button it exited whole MrMC and after going back, channel was schon (without doing anything) in full screen.
Also this list I was missing whole VNSI channel, only IPTV ones are shown, and I did also have only two favorites (All Channel, and favorite) where log shows also others.

Re: LiveTV issue

Posted: 12 May 2019, 11:47
by davilla
no debuglog there :)

Re: LiveTV issue

Posted: 12 May 2019, 11:57
by vrabac
Somehow link by creating post disappeared, i updated my last post, and links goes to my debuglog

Re: LiveTV issue

Posted: 12 May 2019, 15:50
by davilla
streams are garbage with h264 missing required sps, pps info. not sure how these even play on any player.