1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

XML backup issues

Any issues that are tvOS specific
Post Reply
Posts: 6
Joined: 05 Apr 2018, 23:50

XML backup issues

Post by jkhabe » 22 Apr 2018, 14:05

After trying different Kodi boxes, I found MRMC and decided to give it a try on my ATV 4K which, I was already using for Directv NOW, Netflix, Hulu, etc. I am also currently running KODI 17.6 on an Odroid C2 (no HDR) and, I figured MRMC would both give me HDR and, allow me to eliminate one appliance from my HT chain.

I added to a thread in the support section asking for the "Backup" addon to be added. My reasons being:
1. I do not want to run MySQL on my NAS box,
2. I do not want to store the Fanart, poster and nfo files from a separate file XML export in the same folders as my media. I have about 4,000 media files so that would mean cluttering up my media folders with about 12,000 additional files.
3. Single file import does not work correctly. I resort my media files to keep some movies series together (and sorted by chronological order). Examples; D.C., Marvel, Da Vinci Code series, etc... movies that would be scattered alphabetically and not grouped. I would do a single file XML export but, it does not seem to resort the movies correctly on re-import even though the resort tags are definitely contained in the XML file.
4. I prefer to just be able to schedule a weekly backup to a separate folder

Issues (serious):
I am unable to perform an XML export , either single or separate, from my ATV 4K in MRMC and, the last time I tried an export it borked MRMC up to the point of it being so locked/frozen that a reset of the ATV 4K or closing the MRMC app does not un-freeze it.

I can do an export, both single and separate file, from my Odroid C2 running KODI 17.6 to a folder on my NAS with ZERO issues. I was initially able to do a separate file export on the KODI box and import it into MRMC on the ATV 4K so I didn't have to go through renaming, resorting, etc.

I tried doing an export from MRMC but, every time I do, I get zero size files saved to the NAS folder. It is not a permissions issue as again, I have no issues exporting from KODI. I read a thread here where someone else was having issues with zero size file saves and they were informed that "libdsm" (think that is correct name) has to be clicked on if you are backing up to Windows 10 (which I am as my NAS runs Win 10). I tried enabling libdsm and the export started working but, it was excruciatingly slow. Whereas a full backup from my KODI box takes about 20 minutes and the updates in MRMC (although with zero size files) took the same, with libdsm checked on, the export time was at well over 2 hours when it locked up at 87%.

MRMC is now HARD locked. Multiple ATV 4K resets and MRMC app closures will not restart it. BTW, the export was working this time but, it didn't complete obviously.

I am at the point now of having to use my KODI box to do another separate file export, delete MRMC from my ATV 4K, re-install, do an import, and then go delete the 12,000+ files from my media folders that I do not want there.

1. Are people able to successfully perform either a single or separate file xml export on ATV with MRMC?
2. Has anyone else had an export lock their MRMC?
3. Any thoughts on getting an export to work without libdsm enabled or, is it required going to WIn 10?
2. How long do the exports take normally if exporting to a box running Win 10 and libdsm is enabled?

I'm going to set my MRMC back up today but now, I'm really afraid of running into the same issue again if I try another export for backup purposes.



Posts: 6
Joined: 05 Apr 2018, 23:50

Re: XML backup issues

Post by jkhabe » 22 Apr 2018, 18:37


I just did a full XML separate file export from my KODI box, reinstalled MRMC to the ATV 4K and got almost everything set up.

Doing the separate file XML export to my NAS media folders added 23,794 jpg's and nfo's to my media folders so far and I haven't done music yet! I guess I'm going to bite the bullet and leave the files in place and have already synced then to my array.

In a week or so I'll try an XML export from MRMC and hopefully everything goes OK. Still waiting to here if others are having similar issues or if there are fixes.....

Post Reply