Page 4 of 8

Re: Missing Shadow Detail, nothing below 2% black

Posted: 28 Jan 2018, 18:19
by wesk05
I am not in testflight. Just sent an email request.

Re: Missing Shadow Detail, nothing below 2% black

Posted: 28 Jan 2018, 18:27
by davilla
wesk05 wrote:
28 Jan 2018, 18:19
I am not in testflight. Just sent an email request.
done, note the focus handling changes. and taps -> selects

Re: Missing Shadow Detail, nothing below 2% black

Posted: 28 Jan 2018, 18:41
by wesk05
davilla wrote:
28 Jan 2018, 18:27
done, note the focus handling changes. and taps -> selects
Got it! Just now installed.
Was the "Disable limited to full video rescaling" option under "Acceleration" present in previous builds?

Re: Missing Shadow Detail, nothing below 2% black

Posted: 28 Jan 2018, 20:14
by davilla
wesk05 wrote:
28 Jan 2018, 18:41
davilla wrote:
28 Jan 2018, 18:27
done, note the focus handling changes. and taps -> selects
Got it! Just now installed.
Was the "Disable limited to full video rescaling" option under "Acceleration" present in previous builds?
yes, that came in one or two versions ago. note that it will have zero effect under AVFoundationCodec.

Re: Missing Shadow Detail, nothing below 2% black

Posted: 28 Jan 2018, 22:09
by wesk05
I tested the latest testflight build and this is what I see:
1) The issue with 4K 10-bit HEVC non-HDR content triggering HDR output is fixed.
2)The original issue of black & white clipping in HDR mode still persists.
3) SDR output mode is 8-bit dithered. Dithering is being applied to even native 8-bit source.
4) Dithering is affecting the near black levels (16-18/64-78) in SDR mode. This is purely academic, can't say how many will actually notice this issue.

As for what to look for in the test patterns:
1) AVS pattern: when brightness of the display is properly set, the flashing bar 17 should be barely visible.
2)Ryan's pattern: Bar 68 should be barely visible.

In HDR mode, you won't see bars 73-81 even when you set your display's brightness level to max.

Re: Missing Shadow Detail, nothing below 2% black

Posted: 31 Jan 2018, 12:46
by davilla
another fix

(180130.1540) @20180130-b49f0f7
fixed: dolby vision detection for VTB/AVF codecs


Some HDR content could have been switching to Dolby Vision as detecting Dolby Vision in a transport stream (xxx.ts / xxx.m2ts ) was wrong. FFmpeg has been patched to detect and tag Dolby Vision in HEVC Main10 files.

Re: Missing Shadow Detail, nothing below 2% black

Posted: 01 Feb 2018, 07:01
by wesk05
davilla wrote:
31 Jan 2018, 12:46
Some HDR content could have been switching to Dolby Vision as detecting Dolby Vision in a transport stream (xxx.ts / xxx.m2ts ) was wrong. FFmpeg has been patched to detect and tag Dolby Vision in HEVC Main10 files.
I didn't see any difference with the latest build. I remember you mentioning a particular sample being falsely detected as Dolby Vision. I wanted to check that clip, but can't seem to find that post now.

Re: Missing Shadow Detail, nothing below 2% black

Posted: 13 Feb 2018, 18:43
by vinz2k
Hello,

Any news regarding this problem ?

For your information, Infuse has exactly the same problem, since the new version is out. (5.6.8)

Regards,

Re: Missing Shadow Detail, nothing below 2% black

Posted: 13 Feb 2018, 19:48
by cosmoxl
vinz2k wrote:
13 Feb 2018, 18:43
Hello,

Any news regarding this problem ?

For your information, Infuse has exactly the same problem, since the new version is out. (5.6.8)

Regards,
Maybe I'm out of place interjecting here but my understanding is if you're using AVFoundation as the decoder then it's a tvOS problem, not MrMC problem. With AVF, MrMC has no control over rendering (e.g. no contrast/brightness adjustments).

Re: Missing Shadow Detail, nothing below 2% black

Posted: 13 Feb 2018, 19:59
by vinz2k
cosmoxl wrote:
13 Feb 2018, 19:48
vinz2k wrote:
13 Feb 2018, 18:43
Hello,

Any news regarding this problem ?

For your information, Infuse has exactly the same problem, since the new version is out. (5.6.8)

Regards,
Maybe I'm out of place interjecting here but my understanding is if you're using AVFoundation as the decoder then it's a tvOS problem, not MrMC problem. With AVF, MrMC has no control over rendering (e.g. no contrast/brightness adjustments).
You’re right, guys on Infuse forum have contact Apple support for this problem.