1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Testing MrMC 3.9.0 for Google Play

Google Play Store and App Store beta test feedback
Audiomixer
Posts: 26
Joined: 04 Mar 2019, 18:12

Re: Testing MrMC 3.9.0 for Google Play

Post by Audiomixer » 06 Aug 2019, 16:30

That also seems to possibly be a known issue with pie. “The match content color space displaying incorrect format. Root caused, fix in testing, will be part of future 8.0+ HotFix Image.”
The beta, at least for me, was working perfectly with 7.2.3+. All these new issues seems to be pie related. Personally I would stick with the beta.

Ghostm
Posts: 54
Joined: 04 Mar 2019, 02:49

Re: Testing MrMC 3.9.0 for Google Play

Post by Ghostm » 06 Aug 2019, 17:23

Yeah the color space issue was the first thing I noticed but unfortunately has no impact on this, I have to set the colorspace manually until they fix it. It was on rec 709 for these vc-1 files.

H264 and such do display brightness correctly in mrmc yet.

Ghostm
Posts: 54
Joined: 04 Mar 2019, 02:49

Re: Testing MrMC 3.9.0 for Google Play

Post by Ghostm » 07 Aug 2019, 02:46

Same behavior on the public version, i guess the question now is if its defaulting to ffmpeg why is the brightness messed up?

Is it possible its trying to output pc levels 0-255 instead of what i have checked 16-235? Just very odd how washed out vc-1 files are and plex displays them properly yet.

Ghostm
Posts: 54
Joined: 04 Mar 2019, 02:49

Re: Testing MrMC 3.9.0 for Google Play

Post by Ghostm » 07 Aug 2019, 02:50

Well I kind of answered my own question when i turned 16-235 off the problem disappears, so somethings wrong with that. I have 16-235 checked and its a washed out picture. Just with vc-1 files and i believe just since nvidia broke hw acceleration on vc-1.

User avatar
koying
Team MrMC
Posts: 400
Joined: 20 Mar 2016, 17:49

Re: Testing MrMC 3.9.0 for Google Play

Post by koying » 07 Aug 2019, 07:10

Why do you think something's wrong?

It might just mean that shield is using full rather than limited on your setup (depends on the TV capability)
The setting has not effect in Mediacodec, as then the shield itself is handling it, but it's active in software/ffmpeg mode, when we own the full rendering stack...

Ghostm
Posts: 54
Joined: 04 Mar 2019, 02:49

Re: Testing MrMC 3.9.0 for Google Play

Post by Ghostm » 07 Aug 2019, 14:35

Sorry I am a bit confused by the question and just need some clarity.

Why I think something is wrong is because every file plays with proper video levels except vc-1 now.
These Files play fine with proper video levels in plex. Not in mrmc now.
The video is unwatchable and on a calibrated system looks bad.
My tv is calibrated for 16-235 and every other file type looks proper.
These levels were fine before the shield update that sounds like it broke hardware acceleration.

So are you saying the shield has full control over the video levels in this software/ffmpeg mode you are referring to?

If so I will have to go through shield settings and try to find a video level setting as well. I am not sure what plex uses or why i dont observe this issue in that app on the shield.

Even more bizarre though is disabling that 16-235 setting in your software fixes the problem. Again just for vc-1 files. But then right away disabling that the ui is also wrong because that is not how my tv is calibrated (samsung 82nu8000), it was not calibrated for pc levels 0-255.

User avatar
koying
Team MrMC
Posts: 400
Joined: 20 Mar 2016, 17:49

Re: Testing MrMC 3.9.0 for Google Play

Post by koying » 07 Aug 2019, 17:08

Ghostm wrote:
07 Aug 2019, 14:35
Sorry I am a bit confused by the question and just need some clarity.

Why I think something is wrong is because every file plays with proper video levels except vc-1 now.
Ok, now *I* am confused ;)

What's happening if you disable Mediacodec altogether, are VC1 file really the only ones for which you have to change to 0-255 ?

I understood going to 0-255 fixes the problem, but you seem to imply that even so, the quality is not good?

Bottom-line, in your specific case, what is the issue setting MrMC to 0-255?

Ghostm
Posts: 54
Joined: 04 Mar 2019, 02:49

Re: Testing MrMC 3.9.0 for Google Play

Post by Ghostm » 07 Aug 2019, 19:26

So basically to narrow this down.

I have 16-235 selected, before the shield update to 9.0 vc-1 files played fine with proper brightness.

After shield update broke hardware acceleration. Vc-1 files in mrmc with 16-235 selected in the gui look completely washed out with incorrect brightness. My tv is calibrated to 16-235. Every other file type looks fine.

Turning 16-235 off in the gui, vc-1 files look more proper then, but still likely not desirable since my tv is not calibrated for 0-255.

In simplest of terms with 16-235 selected in mrmc currently vc-1 files have a very washed out picture to the point blacks are grey. This effects just vc-1 files.

I dont know if i wait for nvidia to fix the vc-1 hardware acceleration again (not sure when that will be) or if its something we can figure out the software is doing with these files, or a setting i can change so 16-235 looks proper on vc-1 files.


I can try disabling mediacodec tonight to see what happens but i will need that for hdr 4k file playback i assume again.

Ghostm
Posts: 54
Joined: 04 Mar 2019, 02:49

Re: Testing MrMC 3.9.0 for Google Play

Post by Ghostm » 08 Aug 2019, 02:53

Unfortunately disabling media codec surface (all i have enabled) did not do anything, vc-1 files still washed out. All other file types displaying properly with 16-235 setting set.

User avatar
davilla
Team MrMC
Posts: 4150
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.9.0 for Google Play

Post by davilla » 09 Aug 2019, 00:31

Ghostm wrote:
08 Aug 2019, 02:53
Unfortunately disabling media codec surface (all i have enabled) did not do anything, vc-1 files still washed out. All other file types displaying properly with 16-235 setting set.
debuglog :)

Post Reply