1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Mysql on ATV fine, on Ipad connect to mysql ok - but moviefile not found  [SOLVED]

Support for any MySQL database connection issues
Post Reply
Londo2017
Posts: 29
Joined: 19 Sep 2017, 15:37

Mysql on ATV fine, on Ipad connect to mysql ok - but moviefile not found  [SOLVED]

Post by Londo2017 » 19 Feb 2018, 15:47

I switched from emby to mysql today (because of some emby issues, not important) and everything works fine on the atv.

Now i want to use this database on the ipad and purchased mrmc touch full too. Everything the same as on the atv (where it works) The database is found, the movies are shown (without pictures) but if i try to start a movie it says: Movie file not found, should i delete it from the library.

So ive got a working connection to my mysql database, but cannot play on ipad (but on atv).

I tried the same user as atv and try a different new user for ipad - both do the same - Connect to mysql fine, but no movie plays.

User avatar
amet
Team MrMC
Posts: 1865
Joined: 26 Oct 2015, 16:59

Re: Mysql on ATV fine, on Ipad connect to mysql ok - but moviefile not found

Post by amet » 19 Feb 2018, 15:49

same user/pass and same database names?

lets see the debuglog when you try to play same movie from iPad and from ATV please

Londo2017
Posts: 29
Joined: 19 Sep 2017, 15:37

Re: Mysql on ATV fine, on Ipad connect to mysql ok - but moviefile not found

Post by Londo2017 » 19 Feb 2018, 17:02

Thanx for the answer: Debuglog Ipad: - ATV will follow in a few minutes:

17:57:59 T:6167949312 DEBUG: CHomeShelfJob::UpdateTotal() - Running HomeShelf home screen update
17:58:00 T:6167949312 DEBUG: CHomeShelfJob::UpdateTotal() - Finished
17:58:00 T:6158774272 DEBUG: Unfocus WindowID: 10025, ControlID: 50
17:58:00 T:6158774272 DEBUG: SECTION:LoadDLL(libsmbclient.framework/libsmbclient)
17:58:00 T:6158774272 DEBUG: Loading: /var/containers/Bundle/Application/753D7A02-0AAE-4549-985A-A5A4AC6BFB7E/MrMC.app/Frameworks/libsmbclient.framework/libsmbclient
17:58:00 T:6158774272 DEBUG: CPasswordManager:AuthenticateURL hasUserPass(0), path(smb://SYNOLOGY/HD1/Bluray1/abc/abc.mkv)
17:58:00 T:6158774272 DEBUG: OnClick called on 'videodb://movies/titles/1' but file doesn't exist
17:58:00 T:6158774272 DEBUG: ------ Window Init (DialogYesNo.xml) ------
17:58:00 T:6158774272 INFO: Loading skin file: DialogYesNo.xml, load type: KEEP_IN_MEMORY

Londo2017
Posts: 29
Joined: 19 Sep 2017, 15:37

Re: Mysql on ATV fine, on Ipad connect to mysql ok - but moviefile not found

Post by Londo2017 » 19 Feb 2018, 17:08

And ATV (the working one) :-)


18:04:22 T:6161395712 DEBUG: Loading settings for smb://SYNOLOGY/HD1/Bluray1/abc/abc.mkv
18:04:22 T:6161395712 DEBUG: CPlayerCoreFactory::GetPlayers(smb://SYNOLOGY/HD1/Bluray1/abc/abc.mkv)
18:04:22 T:6161395712 DEBUG: CPlayerSelectionRule::GetPlayers: matches rule: system rules
18:04:22 T:6161395712 DEBUG: CPlayerCoreFactory::GetPlayers: adding videodefaultplayer (1)
18:04:22 T:6161395712 DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=0
18:04:22 T:6161395712 DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=1
18:04:22 T:6161395712 DEBUG: CPlayerCoreFactory::GetPlayers: adding player: DVDPlayer (1)
18:04:22 T:6161395712 DEBUG: CPlayerCoreFactory::GetPlayers: added 1 players
18:04:22 T:6161395712 NOTICE: CDVDPlayer::Opening: smb://SYNOLOGY/HD1/Bluray1/abc/abc.mkv
18:04:22 T:6161395712 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:04:22 T:6164836352 NOTICE: Creating InputStream
18:04:22 T:6164836352 DEBUG: CSMBFile::Open - opened HD1/Bluray1/abc/abc.mkv, fd=10001

User avatar
amet
Team MrMC
Posts: 1865
Joined: 26 Oct 2015, 16:59

Re: Mysql on ATV fine, on Ipad connect to mysql ok - but moviefile not found

Post by amet » 19 Feb 2018, 18:04

Please follow the instructions on how to post the full debuglog, we need to see the entire log. Stick it on pastebin please and post link here

Londo2017
Posts: 29
Joined: 19 Sep 2017, 15:37

Re: Mysql on ATV fine, on Ipad connect to mysql ok - but moviefile not found

Post by Londo2017 » 19 Feb 2018, 18:13

I managed to get it worked. I tried so many things out - It has to be some smb Error between my nas and the ipad.

For someone who has got the same issue: I deleted the smb cache in my nas and started the smb service again. And in MrMc i added a single media from smb from the nas - that fixed the smb path for all connections and all movies work now :-) (not only the single one)

Thanks Amet for your kind try to help - Problem is solved (although i do not really know, what the problem was :D )

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests