1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Resume not working on Plex direct play

Support for the native Plex Client on any platform
bgraversen
Posts: 25
Joined: 11 Nov 2016, 02:43

Resume not working on Plex direct play

Post by bgraversen » 12 Apr 2017, 03:48

I'm attempting to resume a movie file at about 51 minutes in and no matter what I do nothing works.

The problem seems to start at this line.
ERROR: CCurlFile::FillBuffer - Failed: Transferred a partial file(18)
This is near the end of the log when I begin playback.

Plex is setup to direct play
Under Internet Access I have a few values different from default
Timeout in Seconds is 120
Buffer size is 200

Log is here - https://pastebin.com/UxYFDP6r

User avatar
davilla
Team MrMC
Posts: 3538
Joined: 26 Oct 2015, 17:01

Re: Resume not working on Plex direct play

Post by davilla » 12 Apr 2017, 13:11

try making the internet timeout longer.

EDIT: error comes from CURLE_OPERATION_TIMEDOUT

bgraversen
Posts: 25
Joined: 11 Nov 2016, 02:43

Re: Resume not working on Plex direct play

Post by bgraversen » 13 Apr 2017, 01:44

I set Timeout in seconds=240 and Amount of Retries=10 with no change. I get the same error messages every time I try to Resume a movie. I tried to start from the beginning of the movie and skip to a later part and that works. This behavior happens with direct play.

With transcode enabled I can resume and skip forward in the movie.

Looxoor
Posts: 129
Joined: 18 Nov 2015, 11:30

Re: Resume not working on Plex direct play

Post by Looxoor » 16 Apr 2017, 15:33

bgraversen wrote:... With transcode enabled I can resume and skip forward in the movie.
What format is the file?
Can you seek and skip by using for example vlc on a computer?
Chances are that the index of file is corrupt, by transcoding that problem is solved.

You could try to extract the tracks of the file using the proper tool (avitools, mkvtools or mp4tools) and create a new new one from the extracted tracks, preferably not avi.

Good luck!

bgraversen
Posts: 25
Joined: 11 Nov 2016, 02:43

Re: Resume not working on Plex direct play

Post by bgraversen » 17 Apr 2017, 18:52

Ok I'll have to have a look at that but I believe this is consistent across all of my media. I package everything with the main video file and highest quality audio in an mkv. I prefer this since the audio is easily transcoded to a different format if needed for an iPhone but I still get the best audio on MrMC. I don't put an AAC track in because it caused problems with direct stream on Plex.

Let me test a few other files and see if I get similar or different behavior.

bgraversen
Posts: 25
Joined: 11 Nov 2016, 02:43

Re: Resume not working on Plex direct play

Post by bgraversen » 20 Apr 2017, 05:16

Alright I had some more time to test this out and I still haven't figured out the problem with resume. This is a consistent problem and I've had no success getting the movie to play from the middle.

Now for the good news...Using Looxoor's advice I looked around for a way to "fix" my file to fix seek. I came across mkclean and after running the file through that it has been a night and day difference. Load times are now under 5 seconds and seek time is nearly instant. The logs also show that MrMC is finding its seek point on Resum but for some reason it exits back to the main menu with no real explanation except for the an eof line.

https://pastebin.com/a72E4EpE

This log contains a start from the beginning and a skip to the middle. I then stopped the movie and attempted to resume it at the point I stopped it from the menu. It did not resume.

User avatar
davilla
Team MrMC
Posts: 3538
Joined: 26 Oct 2015, 17:01

Re: Resume not working on Plex direct play

Post by davilla » 20 Apr 2017, 12:39

yea, 'ERROR: CCurlFile::FillBuffer - Failed: Transferred a partial file(18)'

That's on the hit list to figure out when we move into the next testflight. Only see this if the server has a really slow path to client. In my mind, a partial transfer should not be an error. Should just pass what it has and try again.

My home net connect is really slow, 58KB/s up so when I hit it from the outside world, it's very slow. That's my target test setup.

bgraversen
Posts: 25
Joined: 11 Nov 2016, 02:43

Re: Resume not working on Plex direct play

Post by bgraversen » 20 Apr 2017, 14:25

One thing I did notice with the mkv before using mkclean is that I would get the same partial file transfer errors even with the file locally stored on the server and not on the remote share. The difference is that it would then retry and continue to play. In fact I've had as many as four partial file transfers followed by retries in sequence before it eventually continued.

Let me know if you need some logs and I'll see if I can recreate what I saw or dig up some old logs.

User avatar
davilla
Team MrMC
Posts: 3538
Joined: 26 Oct 2015, 17:01

Re: Resume not working on Plex direct play

Post by davilla » 20 Apr 2017, 14:41

humm, local servers should always be fast. Real fast. Your plex servers are up to date, current version ?

bgraversen
Posts: 25
Joined: 11 Nov 2016, 02:43

Re: Resume not working on Plex direct play

Post by bgraversen » 20 Apr 2017, 16:13

Yes on the current version but I think I caused confusion with my description.

The Plex Media Server is always remote(running on VPS) but the difference in behavior results when Plex accesses the media locally or on a remote share(ACD in my case)

Behavior of Plex Media Server accessing locally stored file - I get the partial file error with the "un-mkclean" mkv but it will retry until it works. Additionally I don't believe I saw the error once I ran the file through mkclean.

Behavior of Plex Media Server accessing a remote share(ACD) - "in-mkclean" mkv has the partial file error and I believe seek is completely broken as there are other errors involved. Playing the mkclean file definitely cleaned up some of the issues but the partial file error does not show any retries. I might have seen an instance where I didn't see the partial file error in this scenario and playback still failed. I'll see if I can replicate that.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests