1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Testing MrMC 3.7.0 - [Invites Closed]

Old TestFlight threads
cosmoxl
Posts: 1407
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by cosmoxl » 14 Aug 2018, 13:12

amet wrote:
14 Aug 2018, 11:47
cosmoxl wrote:
14 Aug 2018, 01:09

Code: Select all

20:04:48.337 T:197347181808   DEBUG: CPlexClient::Init serverName(Desktop), ipAddress(https://192-168-2-10.d099c63a525c4c8787583355000f31de.plex.direct:32400), protocol(https)
20:04:48.337 T:197347181808   DEBUG: CurlFile::Open(0x2df2cefb78) https://192-168-2-10.d099c63a525c4c8787583355000f31de.plex.direct:32400/library/sections
20:04:48.400 T:197347181808   DEBUG: CPlexClient::ParseSections Desktop found 5 movie sections
20:04:48.401 T:197347181808   DEBUG: CPlexClient::ParseSections Desktop found 3 shows sections
20:04:48.401 T:197347181808   DEBUG: CPlexClient::ParseSections Desktop found 0 artist sections
20:04:48.401 T:197347181808   DEBUG: CPlexClient::ParseSections Desktop found 0 photo sections
20:04:48.401 T:197347181808   DEBUG: CurlFile::Open(0x2df2cefb78) https://192-168-2-10.d099c63a525c4c8787583355000f31de.plex.direct:32400/playlists
20:04:48.456 T:197375505648   DEBUG: webserver: request received for /jsonrpc?Player.GetActivePlayers
20:04:48.457 T:197347181808   DEBUG: CPlexClient::ParseSections Desktop found 0 playlist sections
20:04:48.458 T:197347181808  NOTICE: CPlexServices: Server found via plex.tv Desktop
20:04:48.458 T:197347181808   DEBUG: CurlFile::Open(0x2df2cef8b8) https://192-168-1-15.1f411207b4434eeeab23c5fa3676c664.plex.direct:32400/identity
20:04:48.458 T:197347181808    INFO: easy_aquire - Created session to https://192-168-1-15.1f411207b4434eeeab23c5fa3676c664.plex.direct
20:04:48.648 T:197230806256   DEBUG: ------ Window Deinit (DialogExtendedProgressBar.xml) ------
20:04:49.396 T:197347181808   ERROR: CCurlFile::FillBuffer - Failed: Couldn't connect to server(7)
20:04:49.397 T:197347181808   DEBUG: CurlFile::Open(0x2df2cef8b8) https://70-185-203-239.1f411207b4434eeeab23c5fa3676c664.plex.direct:14379/identity
20:04:49.397 T:197347181808    INFO: easy_aquire - Created session to https://70-185-203-239.1f411207b4434eeeab23c5fa3676c664.plex.direct
20:04:49.473 T:197375505648   DEBUG: webserver: request received for /jsonrpc?Player.GetActivePlayers
20:04:53.524 T:197375505648   DEBUG: Previous line repeats 3 times.
20:04:53.524 T:197375505648   DEBUG: webserver: request received for /jsonrpc?System.IsLite
20:04:53.527 T:197375505648   DEBUG: webserver: request received for /jsonrpc?Player.GetActivePlayers
20:04:53.549 T:197375505648   DEBUG: webserver: request received for /vfs%2Fspecial%3A%2F%2Flogs%2Fmrmc.log?1534208693606
20:04:54.399 T:197301093616   DEBUG: CGUIWindowHome::Announce, type: 16, from xbmc, message UpdateRecentlyAdded
20:04:54.399 T:197301093616   DEBUG: CGUIWindowHome::Announce, type: 32, from xbmc, message UpdateRecentlyAdded
20:04:54.401 T:197347181808  NOTICE: UDP: Listening on port 32414
20:04:54.402 T:197347181808   DEBUG: CurlFile::Open(0x2df2cef618) http://192.168.2.10:32400/identity
20:04:54.403 T:197347181808    INFO: easy_aquire - Created session to http://192.168.2.10
20:04:54.405 T:197347181808   ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)
Looking at logs for my Shield to see if I can figure out why the client won't connect to my Plex server.

I'm seeing in the logs an attempt to go to 192.168.1.15. That IP doesn't even exist on my network. My server is at 192.168.2.10. The 70.185.203.239 is a friend's remote server.

Could the attempt to go to a non-existent local IP be the problem?
192.168.1.15 is your friends local lan ip.. we have to test the connections as there is no indication where the server is and on what IP address it’s reachable.

It eventually finds it on 70.185.203.239 ...

Are you not seeing any of your items from “Desktop” plex server?

Code: Select all

20:04:48.337 T:197347181808   DEBUG: CurlFile::Open(0x2df2cefb78) https://192-168-2-10.d099c63a525c4c8787583355000f31de.plex.direct:32400/library/sections
20:04:48.400 T:197347181808   DEBUG: CPlexClient::ParseSections Desktop found 5 movie sections
20:04:48.401 T:197347181808   DEBUG: CPlexClient::ParseSections Desktop found 3 shows sections
On the Shield plex client isn't working for me anymore. On tvOS or iOS it snaps on right away.

I saw that in the log but there's nothing on the screen. :? I even uninstalled MrMC on the Shield, and set it up new. Still didn't work.

I can't explain why others have opposite problems with tvOS being slow.

Thanks for explaining that other internal network IP.

User avatar
amet
Team MrMC
Posts: 2287
Joined: 26 Oct 2015, 16:59

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by amet » 14 Aug 2018, 13:32

Do you see the server list under home server button?

Edit: what version is the shield mrmc? Is it after 31st July?

cosmoxl
Posts: 1407
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by cosmoxl » 14 Aug 2018, 14:30

amet wrote:
14 Aug 2018, 13:32
Do you see the server list under home server button?

Edit: what version is the shield mrmc? Is it after 31st July?
No, latest update for Shield is from July 24.

sigh. sometimes I amaze myself how quickly I forget things. Yes, under the server button my server is there - after I went in and clicked my username in services>plex. I've looked there so many times during my troubles only to find it blank except for local MrMC that I gave up looking.

User avatar
amet
Team MrMC
Posts: 2287
Joined: 26 Oct 2015, 16:59

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by amet » 14 Aug 2018, 14:59

After 31st we have fixed homeshelf not showing items... let’s wait for @koying to prepare another build

User avatar
vlaves
Posts: 131
Joined: 04 Dec 2015, 10:33

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by vlaves » 15 Aug 2018, 06:49

vlaves wrote:
07 Aug 2018, 17:12
Is the new 3.7 version able to use the new FireTV 3 refreshrate seitching feature? The current stable release pauses always and stays pause after refreshrate switching, thats why I am asking?
Can anyone comment on this if 3.7 is tested regarding refresh rate switching on the Fire TV 3? As the current stable build is not working correctly with it.

Thanks for all the great work you guys are doing

Regards/Pozdrav
Vlaves

SUPERBIF
Posts: 131
Joined: 31 Mar 2016, 06:43

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by SUPERBIF » 15 Aug 2018, 07:08

wrxtasy wrote:
14 Aug 2018, 07:41
SUPERBIF wrote:
13 Aug 2018, 08:11
Another problem. When watching Live TV in TF 3.7.0 on Apple TV 4k with TVHeadend the picture starts after a while to not play smooth. I can get it to work again by restarting the Apple TV but it's not optimal. It must be some buffer. It works on the Shield with SPMC. Can I do something to change it?
This has bugged me for quite a while.

Last time I checked, by default full motion YADIF2X deinterlacing is not the default deinterlacing option with watching interlaced content like Live TV on the ATV 4K.

It's a pretty easy fix, when next watching TV, short press the trackpad to bring up the OSD display....

Settings > Video > Deinterlace Method > YADIF2X

Then down the bottom of that panel...

Set as default for all media.

Make sure "Post Processing is OFF" if viewing 1080i TV channels.
Interesting thanks will try it out. I think mine already is YADIF, but unsure if it's 2x or 1/2.

azriel84
Posts: 32
Joined: 03 Apr 2018, 10:44

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by azriel84 » 16 Aug 2018, 00:51

An issue I discovered today. ATV4K, connected to a Yamaha RX V483 receiver (latest firmware), latest tvOS 12 public beta and latest MrMC beta. Playing Avengers Infinity War on 4K HDR Remux (really large file) I got some random frame drops but most notably, distortions in sound, especially after changing scenes back and forth fast. The sound distortion was so bad at times, that the receiver showed the message "decoder off" for some seconds, without any sound, instead of the normal "PCM" and this happened 1-3 times till the app "balanced" the audio output. Resetting the ATV solved the issue, but after using Infuse and returning to MrMC the problems reappeared sometimes more sometimes less frequently, always in scene changes. The weird part is that moving from Infuse to MrMC and backwards for testing purposes, only affected playback on MrMC and not Infuse.

User avatar
wrxtasy
Posts: 26
Joined: 11 Dec 2017, 03:04

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by wrxtasy » 17 Aug 2018, 08:40

BUG - Video Playlists:

Ariana Skin: (so far tested)
I've created a 2160p file name matching Video Playlist, but when I try and back out of the list with the ATV 4K Menu Button I either get a blank screen with ... >

or the original Playlist folder view.

https://pastebin.com/P8VrQNtb

User avatar
koying
Team MrMC
Posts: 281
Joined: 20 Mar 2016, 17:49

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by koying » 17 Aug 2018, 08:58

With latest test?
Pretty sure I had this issue earlier but that it was fixed....

User avatar
wrxtasy
Posts: 26
Joined: 11 Dec 2017, 03:04

Re: Testing MrMC 3.7.0 - [Invites Closed]

Post by wrxtasy » 17 Aug 2018, 09:00

wrxtasy wrote:
17 Aug 2018, 08:40
BUG - Video Playlists:

Ariana Skin: (so far tested)
I've created a 2160p file name matching Video Playlist, but when I try and back out of the list with the ATV 4K Menu Button I either get a blank screen with ... >

or the original Playlist folder view.

https://pastebin.com/P8VrQNtb
Other difficulties I'm facing - video scrubbing:
ATV 4K Dark Mode:

The thin Vertical line when backwards scrubbing gets lost in the white background progress bar really easily.
Infuse now has video thumbnail scrubbing and has the Vertical line poking slightly above the progress bar and it's much easier to see when backwards scrubbing.

Maybe a slight change in scrubber bar color would make this Vertical bar more visible ?

Locked

Who is online

Users browsing this forum: No registered users and 3 guests