1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

M2TS Playback and stuttering on 'busy' scenes

tvOS Video playback support subforum
joelpref
Posts: 19
Joined: 10 Nov 2016, 02:17

M2TS Playback and stuttering on 'busy' scenes

Post by joelpref » 10 Nov 2016, 02:42

I just bought the AppleTV4 app, so on the latest version (2.7), and was running it through the tests on a 45 gb m2ts to replace my outdated wdlive on 100Mb connection. The file played perfectly on the old box, but is really having issues with the MrMC app.

- Using NFS protocol as it is low overhead
- On a RAID Server (4x2GB) - Server 2012 R2
- Wireless AC Connected to AC Router attached to 1GBps server

Seems like there is a lot of overhead and its maxing out the connection on the 5Ghz as seen in screenshots. I only ever hit 80% peak on the WDXLLive NFS over 100Mbps hardwired, so I'm not sure why this is taxing on the wireless.

https://imgur.com/a/zQXCl

Other than that, its a good app, but if it cant replace the old wdlive, I'm not really interested in paying the 11$ for it. Thanks.

User avatar
amet
Team MrMC
Posts: 1500
Joined: 26 Oct 2015, 16:59

Re: M2TS Playback and stuttering on 'busy' scenes

Post by amet » 10 Nov 2016, 06:44

hm, I think we expect too much of AC... in theory its faster than 100mbps LAN but I dont think its more stable.. I have 3 Airport extremes in my house and still all players are hooked up using cat 6 LAN connection.

I think the only test that will show where the issue is is if you were to hook up apple tv using LAN, then you can compare MrMC to WDLive without any interference.

debuglog might show what the issues are, if any, while running LAN connection on Apple TV.

joelpref
Posts: 19
Joined: 10 Nov 2016, 02:17

Re: M2TS Playback and stuttering on 'busy' scenes

Post by joelpref » 10 Nov 2016, 12:28

I'll provide the debug log on both, but when testing on lan connection , it wasn't watchable to the point there was about a 5 second pause just to play a couple frames, likely since AppleTV only has 100Mb. The AC router (asus ac3200) is not a slouch and is really only about 25 feet from the Apple TV , which is why the transfer is able to throughout at 8500kb/s . Tested another m2ts of same size and it ran about 6500 kb/s . Smoother playback, but not perfect .

cosmoxl
Posts: 732
Joined: 12 Dec 2015, 14:16

Re: M2TS Playback and stuttering on 'busy' scenes

Post by cosmoxl » 10 Nov 2016, 13:24

joelpref wrote:I'll provide the debug log on both, but when testing on lan connection , it wasn't watchable to the point there was about a 5 second pause just to play a couple frames, likely since AppleTV only has 100Mb. The AC router (asus ac3200) is not a slouch and is really only about 25 feet from the Apple TV , which is why the transfer is able to throughout at 8500kb/s . Tested another m2ts of same size and it ran about 6500 kb/s . Smoother playback, but not perfect .
if you can get the codec info up on the screen (use a smart phone with official kodi app, hold down the "i" button) check to see if the video bitrate is getting over about 33mbit/s. if it is, the CPU likely can't keep up with decoding.

joelpref
Posts: 19
Joined: 10 Nov 2016, 02:17

Re: M2TS Playback and stuttering on 'busy' scenes

Post by joelpref » 11 Nov 2016, 03:15

ok, here is the logs

new log
http://pastebin.com/FMntCFRM

old log
http://pastebin.com/kWHRDvQr

imgur network utilization and info for codecs
http://imgur.com/a/e2LZ5

it does show at times over 33Mb/s , but if this is a new generation cpu a8 @ 1.5ghz and one that is well over 8 years old @ 500Mhz and it outperforms, then I don't really have a reason to keep this. the bandwidth on both devices , testing again, was only about 56Mb/s maxed out. usually around 40.

cosmoxl
Posts: 732
Joined: 12 Dec 2015, 14:16

Re: M2TS Playback and stuttering on 'busy' scenes

Post by cosmoxl » 11 Nov 2016, 13:59

joelpref wrote:ok, here is the logs

new log
http://pastebin.com/FMntCFRM

old log
http://pastebin.com/kWHRDvQr

imgur network utilization and info for codecs
http://imgur.com/a/e2LZ5

it does show at times over 33Mb/s , but if this is a new generation cpu a8 @ 1.5ghz and one that is well over 8 years old @ 500Mhz and it outperforms, then I don't really have a reason to keep this. the bandwidth on both devices , testing again, was only about 56Mb/s maxed out. usually around 40.
I can't explain the difference in performance of the chips. Does the old box have hardware acceleration? The Apple TV does not provide any API for developers to take advantage of hardware except for m3u8.

So, MrMC just does software decoding. The struggles you're seeing at high bitrates I also see. :(

joelpref
Posts: 19
Joined: 10 Nov 2016, 02:17

Re: M2TS Playback and stuttering on 'busy' scenes

Post by joelpref » 11 Nov 2016, 15:51

thanks @cosmoxl , after buying this app, I'm really no further ahead than keeping my wdlive box hooked up. I saw your post about hardware acceleration, and I agree, this atv box is being oversold and under delivered right now. if I cant play my complete library, might be time to move on or resample them to mkv so don't have to use 2 devices. nice work apple....

User avatar
davilla
Team MrMC
Posts: 2345
Joined: 26 Oct 2015, 17:01

Re: M2TS Playback and stuttering on 'busy' scenes

Post by davilla » 11 Nov 2016, 15:58

Wait for 2.8 before making any rash decisions. that's all I can say right now.

cosmoxl
Posts: 732
Joined: 12 Dec 2015, 14:16

Re: M2TS Playback and stuttering on 'busy' scenes

Post by cosmoxl » 11 Nov 2016, 16:42

davilla wrote:Wait for 2.8 before making any rash decisions. that's all I can say right now.
:o :shock: :ugeek:

User avatar
amet
Team MrMC
Posts: 1500
Joined: 26 Oct 2015, 16:59

Re: M2TS Playback and stuttering on 'busy' scenes

Post by amet » 11 Nov 2016, 17:13

/me queues drumroll for 2.8.0 :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest