1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

advancedsetting.xml and caching

tvOS Video playback support subforum
Post Reply
demonas
Posts: 3
Joined: 21 Mar 2016, 08:19

advancedsetting.xml and caching

Post by demonas » 21 Mar 2016, 08:52

Hi,

I need your help for these issues:

I have a Qnap nas with 40TB, where I put my films and it works fine. All the films are HD, most of them are in uncompressed m2ts files, with a bitrate of 25-30mbits. But now, I want to access remotely to this database. I have fiber links in the two locations, of 200/200mbits. I have done this:

- In the Qnap nas, I create a FTP share, that I can connect by MrMC;

- When I start a film, 3-4 seconds later, it buffers, so I used this parameters, in an advancedsettings.xml file, that I used in Pi:

<advancedsettings>
<network>
<buffermode>1</buffermode> <!-- Comment: Default is 1 -->
<cachemembuffersize>41943040</cachemembuffersize> <!-- Comment: Default is 20971520 bytes or 20 MB -->
<readbufferfactor>4.0</readbufferfactor> <!-- Comment: Default is 1.0 -->
</network>
</advancedsettings>

I tried several combinations of cachemembuffersize and readbufferfactor parameters, but without results. I also trying several combinations of these parameters, in System/Internet options.

I think that using one way, or another, it's not caching, at all. When I play a film, I notice, that the Qnap nas, only send 20-30mbits. When I connect to the FTP share, in a computer with a FTP client, I get 5x the speed.

Another doubt: as I do not see the advancedsettings.xml file, in the Profile Directory, I presume, that every time I copy the file with new parameters, it will replace the older.

Sorry for the long post, but I will appreciate your help.

Thanks in advance.

User avatar
davilla
Team MrMC
Posts: 2346
Joined: 26 Oct 2015, 17:01

Re: advancedsetting.xml and caching

Post by davilla » 21 Mar 2016, 13:18

Those setting have been moved into the GUI, set them there. They will be ignored in the advancedsettings.xml file

demonas
Posts: 3
Joined: 21 Mar 2016, 08:19

Re: advancedsetting.xml and caching

Post by demonas » 21 Mar 2016, 13:47

Thanks Davilla, for your answer.

As I said before, I already tried set them into GUI. I noticed, that the highest value for the memory cache, is 200MB. Is enough ? In your opinion, which is the best value for readbufferfactor, for this case ?

Do you think is possible this scenario or am I wasting my time ?

User avatar
davilla
Team MrMC
Posts: 2346
Joined: 26 Oct 2015, 17:01

Re: advancedsetting.xml and caching

Post by davilla » 21 Mar 2016, 13:52

you know the drill, to look closer, we would need to see mrmc.log with debug enabled.

mrmc.log can be emailed to support@mrmc.tv, remember to include issue details.

demonas
Posts: 3
Joined: 21 Mar 2016, 08:19

Re: advancedsetting.xml and caching

Post by demonas » 21 Mar 2016, 13:53

OK. I will send to you.

Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest