1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Testing MrMC 3.7.1 for Google Play

Any issues that are Nvidia Shield TV specific
cosmoxl
Posts: 1405
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.7.1 for Google Play

Post by cosmoxl » 02 Nov 2018, 17:02

I've gone to the google play link to make sure I'm part of the beta testing. That was 3 days ago. But, still no update to the latest build. :?

cosmoxl
Posts: 1405
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.7.1 for Google Play

Post by cosmoxl » 05 Nov 2018, 21:43

Got an update today. I know some of the work has been to fix audio sync. It seems to me it's worse than before.

I'm having to set a 0.2 second delay to get sync.

https://paste2.org/O3OthOVH

cosmoxl
Posts: 1405
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.7.1 for Google Play

Post by cosmoxl » 06 Nov 2018, 02:21

My setting is that for TV/DVR clicking the TV button takes me directly to the guide. Now when I'm in the guide clicking the back button on the remote brings up the view options. Clicking back again removes view options. Basically I'm stuck in the guide not able to go back to the home screen. If I select another option in the view options, then click the back button, I then can get back to the home screen.

generalmilk
Posts: 2
Joined: 13 Nov 2018, 08:57

Re: Testing MrMC 3.7.1 for Googple Play

Post by generalmilk » 13 Nov 2018, 08:59

supertoto1977 wrote:
21 Oct 2018, 15:20
Hello,

I use MrMc 3.7.1 on my TV Sony AF9 with Android TV Oreo (8.0.0) linked by HDMI ARC to a MDRHW-700DS.
The A/V sync works now. I have no delay by using passthrough (i have to add 530ms in 3.7.0).
But i have a new issue while MrMc has to transcode the audio (DTS, DTS-HD, Dolby-HD) in Dolby AC3.
There's some humming sound. I have to pause and start the movie 2 or 3 times to remove the humming sound and to have a perfect A/V sync.
In the log, you can found a lot of
16:32:44.054 T:18446744072876980592 DEBUG: ActiveAE::SyncStream - average error of -4.846508, start adjusting
16:32:44.054 T:18446744072876980592 DEBUG: ActiveAE::SyncStream - average error -4.846508 below threshold of 30.000000

You can find the debug log here

The IEC passthrough doesn't work. It seems that the IEC is broken on Sony firmware.

Hope it will help to improve MrMc
I can confirm everything you said. Sony X900F

generalmilk
Posts: 2
Joined: 13 Nov 2018, 08:57

Re: Testing MrMC 3.7.1 for Google Play

Post by generalmilk » 13 Nov 2018, 19:52

I know this thread is for Nvidia Shield TV, but the thread in "others" is not active.
For the IEC or "PCM Hack", I think workability has something to do with Sony's system. I have experienced different pass through status on my X900F.
1) DTS and DTS HD (DTS HD receiver support must be off) works as DTS but DD does not work
2) DTS and DD both do not work
3) DTS and DD both works
DD+ never worked in IEC, works when IEC is off

It seems when I fiddle with stock video player or Kodi, plays some videos with different audio codecs, the behavior of IEC in MrMC may change into different status. So far I only experienced 3) once, and it is purely random. Even reboot does not help. Therefore IEC for now is unusable.

supertoto1977
Posts: 2
Joined: 21 Oct 2018, 14:05

Re: Testing MrMC 3.7.1 for Google Play

Post by supertoto1977 » 14 Nov 2018, 18:44

Finally, i bought a Nvidia Shield TV, Sony android firmware is so crappy.
With the Shield, the A/V sync works well, even with the audio transcoding (no humming sound).

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests