1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

The MovieDB Scrape error

Any issues that relate to Addons
Post Reply
doomedtx
Posts: 1
Joined: 02 Aug 2018, 19:14

The MovieDB Scrape error

Post by doomedtx » 02 Aug 2018, 20:38

I'm having trouble scraping a movie that is in themoviedb.org on MrMC (3.6-2 Git:2018-04-25-4528cc1-dirty). Platform: Android ARM 32-bit.

Here's the relevant snippet from the debug log:
16:21:51 T:18446744072810219888 DEBUG: ------ Window Deinit (DialogKeyboard.xml) ------
16:21:51 T:18446744072810219888 DEBUG: VideoInfoScanner: No NFO file found. Using title search for 'smb://N5200XXX/KidsMovies/Advanced Spanish Building on the Basics/Advanced Spanish Building on the Basics.mkv'
16:21:51 T:18446744072810219888 DEBUG: DialogProgress::Open called
16:21:51 T:18446744072810219888 DEBUG: ------ Window Init (DialogProgress.xml) ------
16:21:51 T:18446744072788105584 DEBUG: FindMovie: Searching for 'Advanced Spanish Building' using The Movie Database scraper (path: '/data/user/0/tv.mrmc.mrmc/cache/apk/assets/addons/metadata.themoviedb.org', content: 'movies', version: '3.9.5')
16:21:51 T:18446744072788105584 DEBUG: scraper: CreateSearchUrl returned <url>http://api.tmdb.org/3/search/movie?api_ ... ge=en</url>
16:21:51 T:18446744072788105584 DEBUG: CurlFile::Open(0xc3ddcec0) http://api.tmdb.org/3/search/movie?api_ ... anguage=en
16:21:51 T:18446744072788105584 INFO: easy_aquire - Created session to http://api.tmdb.org
16:21:51 T:18446744072788105584 DEBUG: Get: Using "UTF-8" charset for "http://api.tmdb.org/3/search/movie?api_ ... anguage=en"
16:21:51 T:18446744072788105584 DEBUG: scraper: GetSearchResults returned <results></results>
It seems like there are no results, but pasting the same URL (http://api.tmdb.org/3/search/movie?api_ ... anguage=en) directly does give a result:
{"page":1,"total_results":1,"total_pages":1,"results":[{"vote_count":0,"id":408700,"video":true,"vote_average":0,"title":"Advanced Spanish: Building On The Basics","popularity":0,"poster_path":"\/eKDa79ynsELTKBag8d2VCGUXBd2.jpg","original_language":"en","original_title":"Advanced Spanish: Building On The Basics","genre_ids":[],"backdrop_path":null,"adult":false,"overview":"Do you have a little bit of background with the Spanish language, but want to build on that foundation? Then Estes el programa para ti! (translation: This is the program for you!) First, the award-winning Standard Deviants will review the basics of Spanish, like gender, agreement, conjugation - all the stuff you should already know. Then they'll go over irregular verbs, new verb constructions, making comparisons, adverbs, prepositions, direct and indirect object pronouns, and even prepositional pronouns. This DVD is also chock full of fun scenes and conversations that will help you master the concepts covered.","release_date":""}]}
Is there something I need to change in order to make this movie scrape properly? I'm able to scrape this on SPMC (same Android MiBox) and Kodi (OS X iMac).

Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest