1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

4K/HDR issues Topic is solved

Nvidia Shield TV Video playback support subforum
Post Reply
Quartermass
Posts: 10
Joined: 30 Jul 2018, 00:17

4K/HDR issues

Post by Quartermass » 05 Sep 2018, 21:43

As suggested viewtopic.php?f=10&t=4104&start=1150#p20065 I'm posting a log because I've found MrMC is stuttering/freezing on 4K/HDR content.

The file is a remux so there's lots of data there. I'm using an nVidia shield, it's being output to a Sony STR-DN1080 and from there to an LG OLED65B7V.

https://pastebin.com/K0u7N89Z

I've tried different h/w acceleration options, this is it at default. Some combinations disable HDR (the TV displays when HDR is working) but none seem able to play this file without difficulty.

User avatar
davilla
Team MrMC
Posts: 3661
Joined: 26 Oct 2015, 17:01

Re: 4K/HDR issues

Post by davilla » 06 Sep 2018, 14:30

get codec info up when playing, look at aq/vq and buffers. looks like the net transport can't keep up.

Quartermass
Posts: 10
Joined: 30 Jul 2018, 00:17

Re: 4K/HDR issues

Post by Quartermass » 06 Sep 2018, 15:05

Ok. There have been a couple of changes to the network. I've reterminated a couple of cables up in the loft, and I've replaced the unmanaged switches with managed switches.

That got me thinking and it looks like I need to go reterminate a cable.

https://i.imgur.com/2ZrHkhL.png

Quartermass
Posts: 10
Joined: 30 Jul 2018, 00:17

Re: 4K/HDR issues

Post by Quartermass » 06 Sep 2018, 16:16

So I reterminated the cable showing as crosstalk - before I did it I noticed that the 100 but not 1000 light was on the switch.

I reterminated it twice to no avail. Then remembering that sky TV was put in last week and the guy was behind the TV I pushed on the ethernet cable into the wall port and wiggled.... and the problem has gone.

A simple connection issue!

https://i.imgur.com/AKaoIgE.jpg

That seems to confirm it - not sure why 2 frames were skipped but they seemed to be as it started to play rather that while it was playing. I did take a short video if those numbers are hard to read.

However my guess is the AQ and VQ are fine - or should they be 100%? The buffer I'm guessing is the 150MB and is fine?

If that is solved then I'm down to only having 1 real issue with MrMC.

Thank you for the help!

User avatar
davilla
Team MrMC
Posts: 3661
Joined: 26 Oct 2015, 17:01

Re: 4K/HDR issues

Post by davilla » 07 Sep 2018, 00:04

Codec info looks fine. aq/vq are audio and video demux queues. The 150MB buffer feeds them.

If aq or vq drop to zero, then a buffering cycle starts.

Quartermass
Posts: 10
Joined: 30 Jul 2018, 00:17

Re: 4K/HDR issues

Post by Quartermass » 07 Sep 2018, 00:26

Ah I see.

I think I'll somehow wrangle a way to attach this to the remote so I can turn it on and off.

I've watched the numbers in more detail and sometimes the video queue drops down to 90, and I think the first digit has rolled to an 8 once or twice but from what you've said that's perfectly fine.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest