1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

audio delay and no focus on home menu

Nvidia Shield TV Video playback support subforum
sylvio2000
Posts: 74
Joined: 29 Apr 2016, 17:07

audio delay and no focus on home menu

Post by sylvio2000 » 17 Feb 2017, 19:20

I already posted this in the news thread, but this is the wrong place. Therefor I post it here again with a debug log :)

1. When I start MrMC no menu item is on focus. This means when I press a direction button on my remote nothing happens (but I can hear the click sound). If I press a second time on my remote I can navigate through the home menu.
I am using amber skin with vertical menu.

2. There is an audio delay of maybe half a second in every movie I play. This is only with MrMC. Kodi and SPMC work fine
Audio settings are default in Mr.MC. Stereo, no passthrough, no dsp.... My connection is ShieldTV -- Sony Soundbar -- Panasonic Plasma TV

http://pastebin.com/S7WVy6M5

User avatar
davilla
Team MrMC
Posts: 3435
Joined: 26 Oct 2015, 17:01

Re: audio delay and no focus on home menu

Post by davilla » 18 Feb 2017, 16:17

sylvio2000 wrote:I already posted this in the news thread, but this is the wrong place. Therefor I post it here again with a debug log :)
2. There is an audio delay of maybe half a second in every movie I play. This is only with MrMC. Kodi and SPMC work fine
Audio settings are default in Mr.MC. Stereo, no passthrough, no dsp.... My connection is ShieldTV -- Sony Soundbar -- Panasonic Plasma TV

http://pastebin.com/S7WVy6M5
I reset mine to default for testing. Stereo, no passthrough. Shield TV -> Denon 3200 -> Samsung 4k uhdtv. Played ac3/dts content and a/v sync was spot on. Shield TV has an a/v offset in it's settings, that shows 50ms.

Same under NFS/SMB and Plex.

No clue :) If the offset is always about 1/2, then set it as a global default (scroll down in audio OSD).

Amet is looking into 1)

sylvio2000
Posts: 74
Joined: 29 Apr 2016, 17:07

Re: audio delay and no focus on home menu

Post by sylvio2000 » 18 Feb 2017, 17:55

NVidia Shield is set to 50ms (default)
I have reset Kodi 17 and MrMC 3.0 on my Shield 2015 (5.1). I deleted all data so that I see the "preparing for first run" dialog. This means everything in kodi an MrMC is reset to defaults.

Then the only thing I did was opening the filmanager and started a movie from my media server. In MrMC I have to set audio to ahead for 0.300s.
In kodi everything is fine.

What else can I do? Am I the only one with this problem?

User avatar
davilla
Team MrMC
Posts: 3435
Joined: 26 Oct 2015, 17:01

Re: audio delay and no focus on home menu

Post by davilla » 18 Feb 2017, 18:20

sylvio2000 wrote:NVidia Shield is set to 50ms (default)
I have reset Kodi 17 and MrMC 3.0 on my Shield 2015 (5.1). I deleted all data so that I see the "preparing for first run" dialog. This means everything in kodi an MrMC is reset to defaults.

Then the only thing I did was opening the filmanager and started a movie from my media server. In MrMC I have to set audio to ahead for 0.300s.
In kodi everything is fine.

What else can I do? Am I the only one with this problem?
As far as we know, no one else has reported a/v offset issues. I'd just leave MrMC to 0.3 ahead for everything and don't worry about it :)

cosmoxl
Posts: 1313
Joined: 12 Dec 2015, 14:16

Re: audio delay and no focus on home menu

Post by cosmoxl » 18 Feb 2017, 18:47

no problem with sync here either. I actually have my shield set to 0ms for A/V sync.

Davilla, Amet, the settings for what audio device to use aren't available in MrMC like they are in SPMC. What does MrMC use?

Sylvio, what is your Kodi or SPMC audio device set to? The audio device (not passthrough device) can be PCM, RAW passthrough, or IEC passthrough.

User avatar
davilla
Team MrMC
Posts: 3435
Joined: 26 Oct 2015, 17:01

Re: audio delay and no focus on home menu

Post by davilla » 18 Feb 2017, 19:41

MrMC does not use multiple audio devices like SPMC. The setting that controls non-IEC performs that function. But that only applies for passthrough and Shield should always be IEC.

sylvio case is two channel, no passthrough.

cosmoxl
Posts: 1313
Joined: 12 Dec 2015, 14:16

Re: audio delay and no focus on home menu

Post by cosmoxl » 18 Feb 2017, 20:16

davilla wrote:MrMC does not use multiple audio devices like SPMC. The setting that controls non-IEC performs that function. But that only applies for passthrough and Shield should always be IEC.

sylvio case is two channel, no passthrough.
I am talking about the non-passthrough audio device of SPMC. The options in SPMC are RAW, IEC, or PCM. (passthrough has RAW and IEC options.)

could a difference in audio device account for A/V sync differences?

sylvio2000
Posts: 74
Joined: 29 Apr 2016, 17:07

Re: audio delay and no focus on home menu

Post by sylvio2000 » 19 Feb 2017, 07:28

Kodi 17 uses android audiotrack.
SPMC 16 uses android PCM

User avatar
amet
Team MrMC
Posts: 2040
Joined: 26 Oct 2015, 16:59

Re: audio delay and no focus on home menu

Post by amet » 19 Feb 2017, 11:29

sylvio2000 wrote:I already posted this in the news thread, but this is the wrong place. Therefor I post it here again with a debug log :)

1. When I start MrMC no menu item is on focus. This means when I press a direction button on my remote nothing happens (but I can hear the click sound). If I press a second time on my remote I can navigate through the home menu.
I am using amber skin with vertical menu.
...
I am not seeing the issue, could you take a photo of your home screen so that I can see that it matches mine?... try to catch it when its not in focus.

I have made some changes to possibly fix the issue.. it will be in the next release. Maybe send us your mail and we will include you in testflight... or whatever its called on Shield :)

User avatar
logan_x50
Posts: 89
Joined: 07 May 2016, 06:54

Re: audio delay and no focus on home menu

Post by logan_x50 » 19 Feb 2017, 11:42

I have audio synch issue on every FireTV and FireTV stick (4 in total). this has been the case for a while now...well before mrmc v3

Its like back in the day when when xbmc android was first release all movies needed to have audio offset set to aprox 2.25 ahead. IIRC it may even have been stickied in the forum in the past

I have all audio set at default settings and sound out from the tv (no home cinema/audio out stuff)

as the workaround is simple and i know you guys will ask for debug which is a pain in the butt i thought i'd wait to see if v3 fixed it.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest