1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

New to MrMC and having an issue

Any issues that are Nvidia Shield TV specific
jasonmcroy
Posts: 7
Joined: 09 Aug 2017, 16:41

New to MrMC and having an issue

Post by jasonmcroy » 09 Aug 2017, 19:27

Hello.

I just downloaded the App for MrMC onto my Nvidia Shield last night and I don't know if it's some setting that I am missing or what but I can't seem to get my Videos I have on a USB External hard drive connected to the Shield device to show up in the App.

For a little background, I have used Kodi for a while off and on so I know my way around the App but I know there are some differences in MrMC.

What I am doing is going into Videos from the home screen - Files. On that screen I see "WD Drive" and "Add Videos". In Kodi I have always just selected "WD Drive" then opened the "Nvidia_Shield" folder then long pressed on Bluray Videos and selected "Set Content" and went on from there.

When I try to select "WD Drive" inside of MrMC I get a pop up error "Path not found or invalid" and I can't go any further than that. I am not sure if there is some setting I need to turn on first or if MrMC goes about this a different way but I couldn't find any documentation anywhere that clued me into what I may be doing wrong.

I did set debug logging to on and here is my log file: https://pastebin.com/yRMRmgsK

Let me know if you need anything else.

-Jason

User avatar
davilla
Team MrMC
Posts: 3435
Joined: 26 Oct 2015, 17:01

Re: New to MrMC and having an issue

Post by davilla » 09 Aug 2017, 19:30

ERROR: GetDirectory - Error getting /storage/06121BC8121BBC1D/
ERROR: CGUIMediaWindow::GetDirectory(/storage/06121BC8121BBC1D/) failed

details on 'WD Drive' so we can try to replicate. Which USB port ?, drive format, etc.

jasonmcroy
Posts: 7
Joined: 09 Aug 2017, 16:41

Re: New to MrMC and having an issue

Post by jasonmcroy » 09 Aug 2017, 19:44

Wow, thanks for the fast response!

Ok, it's a WD MY Book 8TB external drive (USB 3.0) that is self powered. I have it plugged into the usb port closest to the other cable at the back of the Shield device (not the furthest one out). It is formatted at NTFS. I originally formatted it on my Windows 10 computer, moved all my video files to it and then plugged it into the Shield TV device. It accepted it and created the Nvidia_Shield folder which is supposed to make that folder writable across your network with the 5.2 update.

The Shield itself is the original (not 2017 version) 500gb pro device.

Thanks.

Rogge B
Posts: 1
Joined: 18 Sep 2017, 16:26

Re: New to MrMC and having an issue

Post by Rogge B » 18 Sep 2017, 16:30

Hi Mrmc,

I have the same problem, new on Mrmc.

I can see the name of external harddrive bur I can not list any
files for playback.

Wrong path.

Everything works with Kodi, VLC etc..

Intenso 1 Tb external usb drive..

regards

Rogge

jasonmcroy
Posts: 7
Joined: 09 Aug 2017, 16:41

Re: New to MrMC and having an issue

Post by jasonmcroy » 18 Sep 2017, 21:11

At least someone else is reporting this as well. I reported this over a month ago and since the one response have seen nothing else about it.

I even tried using a hard drive enclosure with one of my other disks but still got the same issue. I finally had to go back to Kodi which works with it. I just wish I hadn't paid for the player since I haven't been able to get it to work or any communication about it. I payed because I read on the Nvidia Shield TV forums that you can get better support with the paid app. Maybe there aren't enough people with my use case scenario to prompt looking into it very much.

It does work if I add my hard drives located on my HTPC across my network, but I am trying to move away from the HTPC and have everything running just directly on the Shield player in my Living Room.

User avatar
amet
Team MrMC
Posts: 2037
Joined: 26 Oct 2015, 16:59

Re: New to MrMC and having an issue

Post by amet » 19 Sep 2017, 09:57

we have tried replication this with multiple external HDD, its difficult to fix if it cant be reproduced.

I'll make a github issue for it and we will keep trying to reproduce...
https://github.com/MrMC/mrmc/issues/38

Eltax1693
Posts: 1
Joined: 29 Sep 2017, 15:38

Re: New to MrMC and having an issue

Post by Eltax1693 » 29 Sep 2017, 15:44

I'm having the same issue. Can only access my Dlink 327L nas.
Works fine with Kodi and Spmc.

EDIT: WD My Passport 1tb + Verbatim 64gb usb stick.
Used fat32, ntfs and xfat.
Tried all usb ports.

I can see the name of external harddrive/usb stick, but I can not list any
files for playback. Wrong path. [Like Rogge B]
Last edited by Eltax1693 on 29 Sep 2017, 16:05, edited 2 times in total.

User avatar
davilla
Team MrMC
Posts: 3435
Joined: 26 Oct 2015, 17:01

Re: New to MrMC and having an issue

Post by davilla » 29 Sep 2017, 15:47

details please.

Fehritale
Posts: 1
Joined: 26 Mar 2018, 14:48

Re: New to MrMC and having an issue

Post by Fehritale » 26 Mar 2018, 14:53

Same for me.
I can't acces any drive pluged in using the USB Port. It doesn't matter which device, which USB Port, if the device is FAT32/NTFS/exFat. Same results wheter USB Debugging is enabled or disabled.
I'm using the Nvidia Shield TV 2017 (16GB) version. Latest firmware (6.3) and latest MrMC availible.

Prodeje79
Posts: 17
Joined: 21 Mar 2018, 18:24

Re: New to MrMC and having an issue

Post by Prodeje79 » 26 Mar 2018, 22:40

This may not help, nor is pure data. I just felt compelled to share. In my experience, I was plagued with issues on my shield anytime I attempted to use local storage over USB. Random freezing, poor remote response, etc etc. I gave up troubleshooting and simply disconnected all USB devices, which were a USB flash drive and a hard drive. Boom all my weird issues went away. Perhaps it is coincidence or who knows.... maybe I am the only one.

I invested in a synology NAS and now run NFS shares in which Master and Kids profiles point to across multiple devices. Basically one big video folder with 4 folders, tv, movies, kids_tv, and kids_movies to keep them separate. This way the kids can only see the kid friendly stuff.

You can go all in on a DS916+ or just go a simple one or two drive setup. Perhaps the Synology is too expensive, plenty of other means to get some sort of NAS share going without doing local.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests