1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Bug resuming file of combined parts

Support for the native Plex Client on any platform
Post Reply
cosmoxl
Posts: 731
Joined: 12 Dec 2015, 14:16

Bug resuming file of combined parts

Post by cosmoxl » 22 Jul 2017, 13:33

https://gist.github.com/anonymous/97c70 ... 8c30ebb926

There is the log, testing on the ATV4 with the siri remote.

The bug presents when trying to resume playback and the location of the playback is in the second part of the combined file.

From the Movies>In Progress section just clicking on the file results in no action. Holding down the pad and selecting "resume from xxx" results in no action. Holding down the pad and selecting movie information, then selecting play, then selecting "resume from xxx" results in a playback failed message.

From the main movies section (all movies are shown) the same results happen. Except, in this section there is a choice of "play from here" if I hold down the pad. Selecting "play from here" will resume the file at the proper location.

cosmoxl
Posts: 731
Joined: 12 Dec 2015, 14:16

Re: Bug resuming file of combined parts

Post by cosmoxl » 22 Jul 2017, 13:37

Of note, this bug doesn't seem to affect the shield tv app.

User avatar
amet
Team MrMC
Posts: 1499
Joined: 26 Oct 2015, 16:59

Re: Bug resuming file of combined parts

Post by amet » 22 Jul 2017, 13:47

cosmoxl wrote:
22 Jul 2017, 13:37
Of note, this bug doesn't seem to affect the shield tv app.
will have a look, need to find something thats multi part and try .. shield tv app?

please kill Curl logging, makes it impossible to see whats going on in there :)

cosmoxl
Posts: 731
Joined: 12 Dec 2015, 14:16

Re: Bug resuming file of combined parts

Post by cosmoxl » 22 Jul 2017, 13:53

amet wrote:
22 Jul 2017, 13:47
cosmoxl wrote:
22 Jul 2017, 13:37
Of note, this bug doesn't seem to affect the shield tv app.
will have a look, need to find something thats multi part and try .. shield tv app?

please kill Curl logging, makes it impossible to see whats going on in there :)
Yes, I mean MrMC on shield isn't affected.

I see the bug in MrMC on apple tv.

I'll kill curl logging next time.

User avatar
amet
Team MrMC
Posts: 1499
Joined: 26 Oct 2015, 16:59

Re: Bug resuming file of combined parts

Post by amet » 22 Jul 2017, 13:59

thats odd, is it the same version? code is exactly the same on both

cosmoxl
Posts: 731
Joined: 12 Dec 2015, 14:16

Re: Bug resuming file of combined parts

Post by cosmoxl » 22 Jul 2017, 14:26

amet wrote:
22 Jul 2017, 13:59
thats odd, is it the same version? code is exactly the same on both
the apple tv is on the 3.1 testflight. but, that's not the cause of the problem.

I noticed this problem months ago, and even posted about it then, but it was just brought to my attention again last night. :)

cosmoxl
Posts: 731
Joined: 12 Dec 2015, 14:16

Re: Bug resuming file of combined parts

Post by cosmoxl » 24 Jul 2017, 18:03

Amet, have you had a chance to look into this yet?

User avatar
amet
Team MrMC
Posts: 1499
Joined: 26 Oct 2015, 16:59

Re: Bug resuming file of combined parts

Post by amet » 24 Jul 2017, 18:47

cosmoxl wrote:
24 Jul 2017, 18:03
Amet, have you had a chance to look into this yet?
I just did, I cant reproduce with one movie that I have thats multipart... all devices run just fine and resume is ok on all

run it again without curl logging please, lets see if anything stands out

cosmoxl
Posts: 731
Joined: 12 Dec 2015, 14:16

Re: Bug resuming file of combined parts

Post by cosmoxl » 24 Jul 2017, 19:19

ahhh..something jogged my memory and I recalled that when I first brought this bug to your attention you found that plex transcoding was involved in this bug. Sure enough, turning off plex transcoding allows it to work properly.

https://gist.github.com/anonymous/92a91 ... 94e8ecb450

In the log there I tested with transcoding on (doesn't work) and then with transcoding off.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests