1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

FireTV box 1st gen - any recommendations for settings?

FireTV Video playback support subforum
sirmcftv
Posts: 35
Joined: 25 Jul 2017, 16:33

FireTV box 1st gen - any recommendations for settings?

Post by sirmcftv » 25 Jul 2017, 19:01

Just discovered MrMC and trying to use it with a Fire TV box 1st gen, ROM 5.2.1.1 by rbox.

Trouble is I can't get a setup that plays back smoothly. I tried messing with a bunch of settings and I run into one problem or another.

Some info:
- FireTV connected via HDMI to a Denon AVR 3808CI
- Denon via HDMI to a Samsung TV
- Ideally I'd like to have audio passthrough to the AVR so I enabled it. Also set audio channels to 2.0 and enabled transcoding to AC3 so I can get AAC 5.1
- For video I enabled both Mediacodec and Surface

Now for the problems, playing back 23.97 videos w/ DD5.1 audio pass-thru to the AVR:
- If I set MrMC to change the refresh rate, every few seconds there's a slight freeze/skip in the video (the TV info shows 24Hz so it did switch); video looks more like it's playing in slight slow motion
- If I keep MrMC at 60Hz, video looks OK but then the audio skips a bit every few seconds, sometimes the AVR display flashes a bit because it loses the DD5.1 sync but other times it does not, I can just hear the skip during dialog

I'm not sure what combination of settings I should try, or whether I need a different ROM version if 5.2.1.1 is known to have issues?
I'm curious how others are setting up MrMC when hooked up to an AVR and whether there may be settings on the AVR/TV that I should also look at.

Thanks for any guidance in the right direction.

User avatar
davilla
Team MrMC
Posts: 3516
Joined: 26 Oct 2015, 17:01

Re: FireTV box 1st gen - any recommendations for settings?

Post by davilla » 25 Jul 2017, 19:25

Fire TV box 1st gen firmware had a bug in switching refresh rate to 23.97. Seems they forgot to tell kernel the rate changed. Documented in some thread here and not sure they fixed it yet. Looking at logcat will show it. You will get a spew of kernel timeouts regarding vsync.

sirmcftv
Posts: 35
Joined: 25 Jul 2017, 16:33

Re: FireTV box 1st gen - any recommendations for settings?

Post by sirmcftv » 25 Jul 2017, 19:40

davilla wrote:
25 Jul 2017, 19:25
Fire TV box 1st gen firmware had a bug in switching refresh rate to 23.97. Seems they forgot to tell kernel the rate changed. Documented in some thread here and not sure they fixed it yet. Looking at logcat will show it. You will get a spew of kernel timeouts regarding vsync.
I understand this happens on a recent version firmware, I'm on an older one (5.2.1.1) that I stayed on just because of this, even though I don't really care for "correct" refresh rate as long as the content plays well (I prefer to enjoy a movie than for the TV to show the "correct" number on the screen).

It seems there's a 5.2.4.1_r2 version now that may fix the refresh rate switch, but who knows what new problems it introduces. I'd love to hear of a setup that is known to work well so I can try and duplicate it on my side.

User avatar
davilla
Team MrMC
Posts: 3516
Joined: 26 Oct 2015, 17:01

Re: FireTV box 1st gen - any recommendations for settings?

Post by davilla » 25 Jul 2017, 19:49

"If I keep MrMC at 60Hz, video looks OK but then the audio skips a bit every few seconds, sometimes the AVR display flashes a bit because it loses the DD5.1 sync but other times it does not, I can just hear the skip during dialog"

A debuglog when doing this might shed some info on it. The audio should not skip.

sirmcftv
Posts: 35
Joined: 25 Jul 2017, 16:33

Re: FireTV box 1st gen - any recommendations for settings?

Post by sirmcftv » 25 Jul 2017, 20:00

davilla wrote:
25 Jul 2017, 19:49
"If I keep MrMC at 60Hz, video looks OK but then the audio skips a bit every few seconds, sometimes the AVR display flashes a bit because it loses the DD5.1 sync but other times it does not, I can just hear the skip during dialog"

A debuglog when doing this might shed some info on it. The audio should not skip.
I will do so next time I play a video.

Any recommendations when it comes to enabling both Mediacodec and Surface? I believe Surface was disabled by default when I installed MrMC.

User avatar
davilla
Team MrMC
Posts: 3516
Joined: 26 Oct 2015, 17:01

Re: FireTV box 1st gen - any recommendations for settings?

Post by davilla » 25 Jul 2017, 20:32

I run MediaCodec (Surface) enabled with deinterlace disabled, MediaCodec (Non-Surface) enabled. That way interlaced media 'falls' thought MediaCodec (Surface) to MediaCodec (Non-Surface) where the builtin GLES deinterlacers handle interlaced content.

sirmcftv
Posts: 35
Joined: 25 Jul 2017, 16:33

Re: FireTV box 1st gen - any recommendations for settings?

Post by sirmcftv » 25 Jul 2017, 21:31

davilla wrote:
25 Jul 2017, 20:32
I run MediaCodec (Surface) enabled with deinterlace disabled, MediaCodec (Non-Surface) enabled. That way interlaced media 'falls' thought MediaCodec (Surface) to MediaCodec (Non-Surface) where the builtin GLES deinterlacers handle interlaced content.
Thank you. This is on a FireTV 1st gen or some other Android box? Also, I believe you mentioned in another thread that you use a Denon AVR too, if that's the case I'm glad to see we have a somewhat similar setup. Do TV or AVR settings play any role in all this?

User avatar
davilla
Team MrMC
Posts: 3516
Joined: 26 Oct 2015, 17:01

Re: FireTV box 1st gen - any recommendations for settings?

Post by davilla » 26 Jul 2017, 12:49

sirmcftv wrote:
25 Jul 2017, 21:31
Thank you. This is on a FireTV 1st gen or some other Android box? Also, I believe you mentioned in another thread that you use a Denon AVR too, if that's the case I'm glad to see we have a somewhat similar setup. Do TV or AVR settings play any role in all this?
I have FireTV1/2, Shield and AppleTV4. Plus iPhone6S and a few Fire tablets and iPads. Denon W3200 vis HDMI to a Samsung UHDTV. All connected to Samsung run through the Denon amp and have passthrough set with either 5.1 or 7.1 channels. Never had transcode to ac3 setup as this seemed rather pointless. The transcode path would be AAC 5.1 -> MultiChannel PCM -> AC3. Just send the MultiChannel PCM and Denon amp is happy.

That's why I'd like to see the debuglog :)

sirmcftv
Posts: 35
Joined: 25 Jul 2017, 16:33

Re: FireTV box 1st gen - any recommendations for settings?

Post by sirmcftv » 26 Jul 2017, 14:50

Still no debug yet, I have not had a chance to play any videos yet.

Multichannel PCM makes sense, but I was never able to get it to work, in the sense that I'd like my AVR to show 5 ch "MULTI CHAN" on its display for the input, it always says 2 CH and does its own Dolby Pro Logic mode no matter what I tried to set the number of channels in past versions of Kodi, that's why I configured the transcoding to AC3. Perhaps I should try with MrMC again.
I've seen the AVR show "MULTI CHAN" before when I played with the decoding in a Blu-Ray/DVD player so I know it's possible.

Is there a trick to it beyond setting 5.1 channels in the audio output setup in MrMC (I do have "only" a 5.1 setup even though the AVR can do 7.1)?

User avatar
davilla
Team MrMC
Posts: 3516
Joined: 26 Oct 2015, 17:01

Re: FireTV box 1st gen - any recommendations for settings?

Post by davilla » 26 Jul 2017, 14:55

sirmcftv wrote:
26 Jul 2017, 14:50
Still no debug yet, I have not had a chance to play any videos yet.

Multichannel PCM makes sense, but I was never able to get it to work, in the sense that I'd like my AVR to show 5 ch "MULTI CHAN" on its display for the input, it always says 2 CH and does its own Dolby Pro Logic mode no matter what I tried to set the number of channels in past versions of Kodi, that's why I configured the transcoding to AC3. Perhaps I should try with MrMC again.
I've seen the AVR show "MULTI CHAN" before when I played with the decoding in a Blu-Ray/DVD player so I know it's possible.

Is there a trick to it beyond setting 5.1 channels in the audio output setup in MrMC (I do have "only" a 5.1 setup even though the AVR can do 7.1)?
Try it, set channels to 7.1 and see what your Denon does with it. Again, debuglog is always helpful it figuring out what MrMC is actually doing.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests