1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Bugs in version 3.7-0 Fire TV 3

Any issues that are FireTV specific
alekseyz
Posts: 14
Joined: 04 Jan 2017, 19:30

Bugs in version 3.7-0 Fire TV 3

Post by alekseyz » 21 Sep 2018, 01:14

I gave version 3.7-0 a spin. In my observation, it is NOT great. The center remote button now brings up movie information, instead of "Play"; on titles where the movie information is not loaded, it then asks to edit the movie name and if unable to find movie information, which is common with foreign films, sends the menu into a loop. VERY annoying.

Hardware: Amazon Fire TV 3, display set to auto, YCbCr 10 bit, Dolby Digital Plus Automatic, Auto Refresh ON connected directly to Samsung MU8000 4K HDR TV, videos play from WDMycloud NAS connected by 100Mbp wired network with NFS

MrMC:Mediacodec Surface, Auto frame rate "Always", pause 2 seconds, Audio Passthrough ON

Bugs in 3.7-0 not fixed from 3.6-2 (see also the thread about these bugs here http://forum.mrmc.tv/viewtopic.php?f=17 ... fd3273f90d ):

1. Please change the default selection action back to "Play"!
2. When using Mediacodec(Surface) 1080P and up videos start skipping frames, audio goes out of sync after 1-2 minutes then audio becomes choppy and gets out of sync with video. The same video works fine with SPMC 16.7 with Mediacodec (Surface).
3. All videos start "Paused" -- need to un-pause manually, very annoying

The problem with the failure to play a video after the first start of the program was fixed.

User avatar
davilla
Team MrMC
Posts: 3538
Joined: 26 Oct 2015, 17:01

Re: Bugs in version 3.7-0 Fire TV 3

Post by davilla » 21 Sep 2018, 01:30

alekseyz wrote:
21 Sep 2018, 01:14
I gave version 3.7-0 a spin. In my observation, it is NOT great. The center remote button now brings up movie information, instead of "Play"; on titles where the movie information is not loaded, it then asks to edit the movie name and if unable to find movie information, which is common with foreign films, sends the menu into a loop. VERY annoying.

Hardware: Amazon Fire TV 3, display set to auto, YCbCr 10 bit, Dolby Digital Plus Automatic, Auto Refresh ON connected directly to Samsung MU8000 4K HDR TV, videos play from WDMycloud NAS connected by 100Mbp wired network with NFS

MrMC:Mediacodec Surface, Auto frame rate "Always", pause 2 seconds, Audio Passthrough ON

Bugs in 3.7-0 not fixed from 3.6-2 (see also the thread about these bugs here http://forum.mrmc.tv/viewtopic.php?f=17 ... fd3273f90d ):

1. Please change the default selection action back to "Play"!
2. When using Mediacodec(Surface) 1080P and up videos start skipping frames, audio goes out of sync after 1-2 minutes then audio becomes choppy and gets out of sync with video. The same video works fine with SPMC 16.7 with Mediacodec (Surface).
3. All videos start "Paused" -- need to un-pause manually, very annoying

The problem with the failure to play a video after the first start of the program was fixed.
1) you can do that your self, there's a setting for it :)
2) debuglog
3) not a clue, works here.

alekseyz
Posts: 14
Joined: 04 Jan 2017, 19:30

Re: Bugs in version 3.7-0 Fire TV 3

Post by alekseyz » 21 Sep 2018, 01:43

Thank you for your reply
1. EDIT: found this under "VIdeo"->"File lists"
2. I tried to create debug log but I am stuch at "Allow remote control via HTTP" -- the selection fails with "Failed to start" error
3. This problem with videos starting "paused" only occurs when "Match video frame rate" is on in AFTV3 settings and "Adjust video frame rate" option on MrMC is set to "Always", irrespective of what the "Delay" set for in MrMC. Please see previous posts about this problem in 3.6-2 -- I am not the only one

alekseyz
Posts: 14
Joined: 04 Jan 2017, 19:30

Re: Bugs in version 3.7-0 Fire TV 3

Post by alekseyz » 21 Sep 2018, 03:04

I was able to get the web server started after wiping data and starting anew. I captured the log up to the point where video started stuttering and audio was out of sync. The log is here:

https://1drv.ms/t/s!ApFXUbzQNyZ_gf8AyoXUwXBPwPN9bQ

alekseyz
Posts: 14
Joined: 04 Jan 2017, 19:30

Re: Bugs in version 3.7-0 Fire TV 3

Post by alekseyz » 21 Sep 2018, 03:25

There are AudioTrack errors:

23:21:40.356 T:18446744072903723296 ERROR: AESinkAUDIOTRACK::GetDelay over-write error, frameSize=4, headBytes=18446744065119617024, m_writeBytes=330240
23:21:40.359 T:18446744072903723296 ERROR: CAESinkAUDIOTRACK::AddPackets write returned error: -12
23:21:40.359 T:18446744072903723296 ERROR: CActiveAESink::OutputSamples - sink returned error

mirko1312
Posts: 12
Joined: 31 Jul 2018, 17:54

Re: Bugs in version 3.7-0 Fire TV 3

Post by mirko1312 » 21 Sep 2018, 07:58

I can confirm these bugs (2) and (3) and can confirm they only happen when autoframe rate is ON in Fire TV settings.
A/V is out of sync with amc(S) and playback always starts paused (regardless of "always" or "start/stop" framerate settings in kodi)

Since auto framerate option is currently available only on Fire TV 3 (pendant) I guess this device needs some special attention.

mirko1312
Posts: 12
Joined: 31 Jul 2018, 17:54

Re: Bugs in version 3.7-0 Fire TV 3

Post by mirko1312 » 21 Sep 2018, 08:08

And i would like to add bug number (4). DD Passthrough not working.
Options used in FTV :display set to auto, YCbCr 10 bit,Audio: Dolby Digital Auto(default option is DD Plus auto), Auto Refresh ON

With these settings I get full DD 5.1 passthrough in Krypton, Plex and Emby official client.

In MrMC when playing a DD movie/show output stays on default Dolby 2.1 output not triggering a switch to 5.1 DD. (When I say default 2.1 DD i mean default because as soon as you choose audio option in FTV settings : DD Auto (instead of D
default one - DD Plus Auto) all audio from the box starts to output this 2.0/2.1 DD (thats what my AVR say). Resumen: After starting a video in MrMC the output stays in this mode. Kodi/Emby/Plex ttigger my AVR to change to 5.1 DD output.
Last edited by mirko1312 on 28 Sep 2018, 18:00, edited 1 time in total.

alekseyz
Posts: 14
Joined: 04 Jan 2017, 19:30

Re: Bugs in version 3.7-0 Fire TV 3

Post by alekseyz » 21 Sep 2018, 11:46

So far SPMC 16.7.4 works (almost) fine with Fire TV 3. There are tricks though. Under Acceleration you have to set all codecs to "Always", set HQ scalers to "Never" , and enable Mediacodec (Surface). "Adjust frame rate" to "Always" with 1.5sec delay. Then all videos work smoothly including HDR and 24p. EDIT: Set UI to 720p60 to let the TV do the upscaling.

Audio passthrough workaround: set to IEC passthrough and enable passthrough of everything excluding the DTSHD and TRUEHD, then DISABLE passthrough, otherwise you have no sound. When video starts playing, pause it, go to the audio OSD menu and enable passthrough from there and it works! But you have to disable/enable it from that menu every time you start a new video video otherwise you get no sound.

Other than the passthrough issue (can work around) SPMC 16.7.4 works perfectly on Fire TV 3 (THANK YOU Koying!).

I have a soundbar with Fire TV 3 in the living room, so I can live without passthrough. I have Libreelec on my 7.1 system in the basement.

sumpfgottheit
Posts: 1
Joined: 23 Sep 2018, 19:00

Re: Bugs in version 3.7-0 Fire TV 3

Post by sumpfgottheit » 23 Sep 2018, 19:33

Fire TV 3 owner and MrMc 3.7 user here. Graded up from FTV2 to FTV3 due to the new autoframerate switching.

Playback with default surface codec is horribly out of sync(x264 and x265) - a few seconds - the non surface code seems to be 0.1ms out of sync. I use the autoframerate switching, of course.

The out of sync is not stable but changes throughout the movie, from +0.1 to -0.3ish...

The starting paused problem is a bit annoying, but I guess it is easily fixable.

Never had problems like this on the FTV2. Can‘t get a debuglog right now, but will do so later this week.

jumbo_
Posts: 2
Joined: 16 Oct 2017, 15:53

Re: Bugs in version 3.7-0 Fire TV 3

Post by jumbo_ » 23 Sep 2018, 21:55

I can confirm the video bufferring/audio issue as well but on Fire TV2. Ever since the upgrade to 3.7 the audio gets totally out of sync very soon by a ~0.5s, and drifts away to from couple seconds to even 10s - just depends on how long the movie is playing.

I seems to be definitely connected to the "Auto frame rate" setting, since without it the Video queue is always ~99%, but with this setting after while the VQ goes down to 0% - which is when the audio starts to sync out completely.

Debug log: https://paste.ee/p/DPiJ2

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests