1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Crashing when setting up music source

Any issues that are tvOS specific
Grumpy1954
Posts: 11
Joined: 03 Oct 2018, 16:55

Re: Crashing when setting up music source

Post by Grumpy1954 » 26 Nov 2018, 18:04

Here we go again!

Everything has been working perfectly, until this morning.

I'd added some music, went to files to scan to the library, and....crash.

Did a bit of investigation, and it works on everything except files.

I tried removing the files I added, cleaned the library, nothing doing.

Also did a restart, both of the Apple TV and NAS, same result.

Haven't yet tried setting up a new source, which is what cured the issue last time. I don't mind doing that, but I'd like to get to the bottom of whatever is causing this.

What really puzzles me is that yesterday it was working like a dream, and today it's being a right pain.

https://pastebin.com/TR80FRgG

User avatar
amet
Team MrMC
Posts: 2278
Joined: 26 Oct 2015, 16:59

Re: Crashing when setting up music source

Post by amet » 26 Nov 2018, 18:07

try getting debuglog old, that would be from the previous session that crashed

Grumpy1954
Posts: 11
Joined: 03 Oct 2018, 16:55

Re: Crashing when setting up music source

Post by Grumpy1954 » 26 Nov 2018, 18:32

https://pastebin.com/gjCLHE9Q

debuglog old as requested

And, as ever, thanks for your help with this

Grumpy1954
Posts: 11
Joined: 03 Oct 2018, 16:55

Re: Crashing when setting up music source

Post by Grumpy1954 » 27 Nov 2018, 16:55

Bit of extra info, it's also crashing if I try and launch photos.

Don't think it did that last time I had this issue but that may simply be because I hadn't yet set up a photos source.

Again, previously it was working perfectly, this time yesterday in fat. So post my original problem.

User avatar
amet
Team MrMC
Posts: 2278
Joined: 26 Oct 2015, 16:59

Re: Crashing when setting up music source

Post by amet » 27 Nov 2018, 17:20

you are using libdsm, what is your server? does it happen if you use other smb service? libsmb2 or if you deselect all?

EDIT: we can get you into TestFlight, we have some changes in libdsm there. alternatively, 3.7.1 will be out in the next few weeks

Grumpy1954
Posts: 11
Joined: 03 Oct 2018, 16:55

Re: Crashing when setting up music source

Post by Grumpy1954 » 28 Nov 2018, 10:39

Changed to libsmb2, and all seems happy now.

The only reason I was using libdsm was because when I had this issue previously it simply refused to work with libsmb2 so I carried on as before.

thanks and fingers crossed!

Grumpy1954
Posts: 11
Joined: 03 Oct 2018, 16:55

Re: Crashing when setting up music source

Post by Grumpy1954 » 06 Dec 2018, 17:20

OK, given things a week or so to see if anything nasty happened, but, so far at least all is happy and smiling.

Many thanks for the help

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests