1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Cannot connect to SMB share on 3.7

Any issues that are tvOS specific
ionutm80
Posts: 9
Joined: 04 Apr 2018, 06:32

Cannot connect to SMB share on 3.7

Post by ionutm80 » 19 Sep 2018, 06:57

Hi guys,

I have a Windows 10 machine acting as a homeserver from which I share my video files, nothing special just right click on the folder => sharing => advanced sharing => permisssions and add "Everyone" user with read rights.
After updating last night to MrMC 3.7 I can no longer connect to these SMB shares. I have tried the following: Add network location => Protocol: SMB, Server Name: both local network IP address (192.168.1.2xx) or server name (WIN-HOMESERVER) and also Username and Password the result being "Timed Out"... all these with default setting on Settings/Services/SMB. I then checked "Use libsmb2 for smb servers" but no success either in this case. I have the same problem also with MrMC Touch on mu iPhone 8 by the way. I have even deleted then reinstalled MrMC and even restarted both Apple TV 4k and iPhone 8 with no success.
The same network credentials are working perfectly in Infuse, both for tvOS and iOS.

Please advise what am I doing wrong or what has changed in 3.7 regarding SMB shares.

Thanks.

User avatar
davilla
Team MrMC
Posts: 3668
Joined: 26 Oct 2015, 17:01

Re: Cannot connect to SMB share on 3.7

Post by davilla » 19 Sep 2018, 12:48

which mrmc/smb client ? libsmbclient, libdsm or libsmb2.

Note: for libsmb2, it supports smb2/smb3 protocols and requires user/pass AND share point when setting it up.

ionutm80
Posts: 9
Joined: 04 Apr 2018, 06:32

Re: Cannot connect to SMB share on 3.7

Post by ionutm80 » 19 Sep 2018, 13:52

Tried libsmbclient ==> "Timeout ..." error
Tried libsmb2 ==> something about the network share not being available or the ATV4K not being connected to the network, I can post some photos this evening.
What do you mean by :"shared point"? Are you referring to shared folder?I only have: Protocol, Server Name, Browse, Shared Folder, Username and Password.

With both libsmbclient and libsmb2 I have input the following fields:
Protocol: SMB
Server Name: tried both of IP address (192.168.1.2xx) or server name (WIN-HOMESERVER)
Username: XYZ
Password: XYZ

ionutm80
Posts: 9
Joined: 04 Apr 2018, 06:32

Re: Cannot connect to SMB share on 3.7

Post by ionutm80 » 19 Sep 2018, 21:00

@davilla : I've managed to connect in the end and all it's fine now. It is exactly as you said with libsmb2 you have to input also the shared folder in order for the SMB share to become visible.

Thanks a lot! It's also working on the iPhone 8 by the way.

Dogstar
Posts: 6
Joined: 20 May 2017, 10:32

Re: Cannot connect to SMB share on 3.7

Post by Dogstar » 22 Sep 2018, 09:45

Hi,

I also have the problem, that I can't connect to my SMB shares after updating to V3.7. I always get an authentication error code 6.

I have two file servers running under Windows Server 2016 and a NAS. All devices are in an Active Directory. I don't have any problems with other tvos apps on my Apple TV 4K using SMB.

These are my network location settings:

Protocol: Windows network (SMB)
Server name: Servername.domain
Shared folder: Name of the shared folder (contains spaces)
Username: Domain\Username
Password: Password

Is this correct or do I have something else to consider?

Update: I now don‘t have any spaces in the names of my shares. I tried all combinations of with or without libsdm and libsmb2, but no chance. I tried server names with or without domain and just the IP addresses: no chance. Username with and without domain: no chance. I don‘t know what else I could try.

User avatar
davilla
Team MrMC
Posts: 3668
Joined: 26 Oct 2015, 17:01

Re: Cannot connect to SMB share on 3.7

Post by davilla » 28 Sep 2018, 02:01

debuglog please

Dogstar
Posts: 6
Joined: 20 May 2017, 10:32

Re: Cannot connect to SMB share on 3.7

Post by Dogstar » 28 Sep 2018, 11:37

Log says:

CDSMSession: Failed to connect using SMB_TRANSPORT_TCP, trying SMB_TRANSPORT_NBT
ERROR: CDSMSession: Failed to connect
GetDirectory - Error getting smb://USERNAME:PASSWORD@Server/Share/
ERROR: CGUIDialogFileBrowser::GetDirectory(smb://USERNAME:PASSWORD@Server/Share) failed

User avatar
davilla
Team MrMC
Posts: 3668
Joined: 26 Oct 2015, 17:01

Re: Cannot connect to SMB share on 3.7

Post by davilla » 29 Sep 2018, 01:20

How was MrMC setup before the update ? Using libsmbclient, libdsm or libsmb2 ?

Dogstar
Posts: 6
Joined: 20 May 2017, 10:32

Re: Cannot connect to SMB share on 3.7

Post by Dogstar » 29 Sep 2018, 06:04

libsmbclient

User avatar
davilla
Team MrMC
Posts: 3668
Joined: 26 Oct 2015, 17:01

Re: Cannot connect to SMB share on 3.7

Post by davilla » 29 Sep 2018, 14:51

Dogstar wrote:
29 Sep 2018, 06:04
libsmbclient
please return to using libsmbclient and debuglog

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 7 guests