1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Choppy Sound on TVOS

Any issues that are tvOS specific
User avatar
brian@guzanet.com
Posts: 25
Joined: 28 Jan 2018, 20:53

Choppy Sound on TVOS

Post by brian@guzanet.com » 01 Apr 2018, 14:16

Hi. I have been having an intermittent problem for a while now with Apple TV. While watching Plex-hosted shows, the audio will have very tiny "breaks" that are just enough to be noticed ... and enough to be annoying. If music is playing or there is dialog, it will go silent and back on for a very short time.

I have never seen this behavior in the same shows when using the ATV Plex client or any other front-end on ATV. It only seems to happen in MrMC.

I have finally found a particular time at a particular episode where this happens consistently. However, if I cut the video to a short clip, this doesn't seem to happen. Also, I can never get this to happen anywhere on my PC. I only have one ATV, so can't completely rule out the fact that it is not something in my particular setup. However, if it was setup related I would assume that I would see the problem in the Plex client.

If someone wanted to take a look at this...what would be a good way to proceed? I'm happy to grant temporary access to Plex if anyone wants to take a look.



thanks
BrianGG

cosmoxl
Posts: 1084
Joined: 12 Dec 2015, 14:16

Re: Choppy Sound on TVOS

Post by cosmoxl » 01 Apr 2018, 14:22

do you have sync video to display switched on?

User avatar
davilla
Team MrMC
Posts: 3151
Joined: 26 Oct 2015, 17:01

Re: Choppy Sound on TVOS

Post by davilla » 01 Apr 2018, 14:24

want to see a debuglog first.

User avatar
brian@guzanet.com
Posts: 25
Joined: 28 Jan 2018, 20:53

Re: Choppy Sound on TVOS

Post by brian@guzanet.com » 01 Apr 2018, 17:59

Regarding Sync Video setting: I have this setting turned off. When I turned this on and tested on the same movie clip...results were MUCH worse. It was more choppy than smooth.


With Sync Video off, the below PasteBin was on during at least 3 separate chops (all very small) during about 1 minute of viewing:


DebugLog

User avatar
davilla
Team MrMC
Posts: 3151
Joined: 26 Oct 2015, 17:01

Re: Choppy Sound on TVOS

Post by davilla » 01 Apr 2018, 18:05

DEBUG: DumpAudioDescriptions : portName, Great Room

are you casting audio to some airport device ?

User avatar
brian@guzanet.com
Posts: 25
Joined: 28 Jan 2018, 20:53

Re: Choppy Sound on TVOS

Post by brian@guzanet.com » 01 Apr 2018, 18:09

GREAT ROOM is just the name of my AppleTV.
Standard setup: Wired ethernet, HDMI ATV into TV. TV optical into receiver.

User avatar
davilla
Team MrMC
Posts: 3151
Joined: 26 Oct 2015, 17:01

Re: Choppy Sound on TVOS

Post by davilla » 01 Apr 2018, 18:10

brian@guzanet.com wrote:
01 Apr 2018, 18:09
GREAT ROOM is just the name of my AppleTV.
Standard setup: Wired ethernet, HDMI ATV into TV. TV optical into receiver.
So using ARC return from HDTV back to receiver ?

User avatar
brian@guzanet.com
Posts: 25
Joined: 28 Jan 2018, 20:53

Re: Choppy Sound on TVOS

Post by brian@guzanet.com » 01 Apr 2018, 18:20

I had to look up what ARC meant, but yes. :P

All of my inputs go into my HDTV via HDMI and everything funnels into a single output from TV to stereo receiver.

User avatar
brian@guzanet.com
Posts: 25
Joined: 28 Jan 2018, 20:53

Re: Choppy Sound on TVOS

Post by brian@guzanet.com » 04 Apr 2018, 09:22

Any suggestions here ?
The problem continues on nearly every show I watch now.

User avatar
davilla
Team MrMC
Posts: 3151
Joined: 26 Oct 2015, 17:01

Re: Choppy Sound on TVOS

Post by davilla » 04 Apr 2018, 11:59

On the list to check, others are also running ARC setups and they have not reported any issues.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests