1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

TvOs 11.3 beta no audio only noise

Any issues that are tvOS specific
Golge77
Posts: 30
Joined: 20 Dec 2017, 13:56

TvOs 11.3 beta no audio only noise

Post by Golge77 » 26 Jan 2018, 16:14

After installing 11.3 beta I lost all sound in MrMc I'm only get noise in the speakers.
It doesn't matter if it's 2 channel or 5.1 etc.

Sound works in Infuse 5 pro and other streaming apps

anyone else having this problem?

cosmoxl
Posts: 1407
Joined: 12 Dec 2015, 14:16

Re: TvOs 11.3 beta no audio only noise

Post by cosmoxl » 26 Jan 2018, 16:18

how is your sound setup in MrMC and in the tvOS settings?

I have the 11.3 beta on an ATV4k and an ATV4 with no problems that I've noticed.

Golge77
Posts: 30
Joined: 20 Dec 2017, 13:56

Re: TvOs 11.3 beta no audio only noise

Post by Golge77 » 26 Jan 2018, 16:33

MrMc
* 7.1
* Optimized
* Keep original volume......
* Resampling quality ............High

* passthrough:
* Dolby digital AC3
* DTS

tvOs
* Sound output: AppleTV4k
* Surroundsound: Best available quality

I have my menus in other language so I'm not sure if my translation is the right one ....


After some more testing it seems like the problem is with dolby digital sounds 2.0, 5.1 and 7.1

AAC 2.0, 5.1 and 7.1 works

cosmoxl
Posts: 1407
Joined: 12 Dec 2015, 14:16

Re: TvOs 11.3 beta no audio only noise

Post by cosmoxl » 26 Jan 2018, 16:45

Golge77 wrote:
26 Jan 2018, 16:33
MrMc
* 7.1
* Optimized
* Keep original volume......
* Resampling quality ............High

* passthrough:
* Dolby digital AC3
* DTS

tvOs
* Sound output: AppleTV4k
* Surroundsound: Best available quality

I have my menus in other language so I'm not sure if my translation is the right one ....


After some more testing it seems like the problem is with dolby digital sounds 2.0, 5.1 and 7.1

AAC 2.0, 5.1 and 7.1 works
Right, so it's passthrough that's not working since AAC works. This is typical of betas. If your audio sink can take multi channel PCM, turning off passthrough in MrMC is probably the best choice for stability and quality.

Golge77
Posts: 30
Joined: 20 Dec 2017, 13:56

Re: TvOs 11.3 beta no audio only noise

Post by Golge77 » 26 Jan 2018, 16:49

Why does it work in Infuse and not in MrMc?
If passthrough was broken I should have the same problem with Infuse.

User avatar
davilla
Team MrMC
Posts: 3661
Joined: 26 Oct 2015, 17:01

Re: TvOs 11.3 beta no audio only noise

Post by davilla » 26 Jan 2018, 16:52

Golge77 wrote:
26 Jan 2018, 16:49
Why does it work in Infuse and not in MrMc?
If passthrough was broken I should have the same problem with Infuse.
If Infuse was open source and I could look at their audio code handling, then I could answer that question. :)

Seriously, this is the 1st beta of tvOS 11.3, surly you guys would learn by now, never test the 1st beta of a version bump. There is always something that breaks. I never, ever install the 1st beta of anything. It's just a waste of time.

cosmoxl
Posts: 1407
Joined: 12 Dec 2015, 14:16

Re: TvOs 11.3 beta no audio only noise

Post by cosmoxl » 26 Jan 2018, 16:53

Golge77 wrote:
26 Jan 2018, 16:49
Why does it work in Infuse and not in MrMc?
If passthrough was broken I should have the same problem with Infuse.
I couldn't tell you. So in Infuse you have it set to passthrough, not auto?

Golge77
Posts: 30
Joined: 20 Dec 2017, 13:56

Re: TvOs 11.3 beta no audio only noise

Post by Golge77 » 26 Jan 2018, 17:02

davilla wrote:
26 Jan 2018, 16:52
Golge77 wrote:
26 Jan 2018, 16:49
Why does it work in Infuse and not in MrMc?
If passthrough was broken I should have the same problem with Infuse.
If Infuse was open source and I could look at their audio code handling, then I could answer that question. :)

Seriously, this is the 1st beta of tvOS 11.3, surly you guys would learn by now, never test the 1st beta of a version bump. There is always something that breaks. I never, ever install the 1st beta of anything. It's just a waste of time.
There's no rush a new beta coming soon anyway.... meanwhile I can use infuse and I also have 2 Nvidia Shields so I can watch my movies/series anyway

cosmoxl
Posts: 1407
Joined: 12 Dec 2015, 14:16

Re: TvOs 11.3 beta no audio only noise

Post by cosmoxl » 26 Jan 2018, 19:44

Golge77 wrote:
26 Jan 2018, 17:02
davilla wrote:
26 Jan 2018, 16:52
Golge77 wrote:
26 Jan 2018, 16:49
Why does it work in Infuse and not in MrMc?
If passthrough was broken I should have the same problem with Infuse.
If Infuse was open source and I could look at their audio code handling, then I could answer that question. :)

Seriously, this is the 1st beta of tvOS 11.3, surly you guys would learn by now, never test the 1st beta of a version bump. There is always something that breaks. I never, ever install the 1st beta of anything. It's just a waste of time.
There's no rush a new beta coming soon anyway.... meanwhile I can use infuse and I also have 2 Nvidia Shields so I can watch my movies/series anyway
I don't know what content your video files have but you really will get better audio decoding by disallowing passthrough. You see, if passthrough is enabled then MrMC in tvOS will try to passthrough the DTS core of DTS-HD. If passthrough is disabled then it will decode DTS-HD and output PCM. Just a thought. I know I'd rather have DTS-HD.

Golge77
Posts: 30
Joined: 20 Dec 2017, 13:56

Re: TvOs 11.3 beta no audio only noise

Post by Golge77 » 27 Jan 2018, 04:11

probably I have to reverse my thinking when setting up AppleTV.
I'm used to other mediaplayers and for atleast 10 years I have set passthrough in settings to let amplifier decode and show Dolby Digital, DTS and lately DtsHD-MA, TrueHD and Atmos.

I will try to skip passthrough and see what happens

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests