1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Forced ASS subtitles not showing  [SOLVED]

Any issues that are tvOS specific
User avatar
timstephens24
Posts: 706
Joined: 09 Dec 2015, 22:43

Forced ASS subtitles not showing

Post by timstephens24 » 14 Jan 2018, 01:12

I have subtitles set to 'Forced Only' since I go in and set the non-English subtitles to forced and default, and turn it off for all the others. It's worked well, but I added some new files today with ASS subtitles, and it doesn't work with those. To test, I went and played X-Men: Apocalypse and checked the settings and the subtitles were enabled. I then went and played an episode of Boruto I ripped today and the subtitles aren't enabled. I also checked Plex and they're showing in Plex as what to play, and my MrMC is setup with Plex.

(Since I just learned how to rip these today I figured it would need a new topic and not in TestFlight since I'm not sure if it's a new issue or not.)

Debug log:
https://pastebin.com/Vp3K1zBH

X-Men Apocalypse subtitle track

Code: Select all

Text
ID                                       : 3
Format                                   : PGS
Codec ID                                 : S_HDMV/PGS
Codec ID/Info                            : Picture based subtitle format used on BDs/HD-DVDs
Title                                    : English (Forced only)
Language                                 : English
Default                                  : Yes
Forced                                   : Yes
Statistics Tags Issue                    : mkvmerge v16.0.0 ('Protest') 64-bit 2017-10-08 23:25:06 / Lavf57.71.100 
FromStats_BitRate                        : 1968
FromStats_Duration                       : 01:29:52.470000000
FromStats_FrameCount                     : 186
FromStats_StreamSize                     : 1277698
Boruto subtitle track

Code: Select all

Text
ID                                       : 3
Format                                   : ASS
Codec ID                                 : S_TEXT/ASS
Codec ID/Info                            : Advanced Sub Station Alpha
Compression mode                         : Lossless
Title                                    : Boruto Naruto Next Generations
Language                                 : English
Default                                  : Yes
Forced                                   : Yes
Statistics Tags Issue                    : mkvmerge v8.8.0 ('Wind at my back') 64bit 2018-01-13 19:20:09 / Lavf58.3.100 
FromStats_BitRate                        : 127
FromStats_Duration                       : 00:23:53.530000000
FromStats_FrameCount                     : 371
FromStats_StreamSize                     : 22780

User avatar
davilla
Team MrMC
Posts: 3538
Joined: 26 Oct 2015, 17:01

Re: Forced ASS subtitles not showing

Post by davilla » 14 Jan 2018, 01:51

can we get a sample ?

User avatar
timstephens24
Posts: 706
Joined: 09 Dec 2015, 22:43

Re: Forced ASS subtitles not showing

Post by timstephens24 » 14 Jan 2018, 02:26

Shot a gdrive link to support@mrmc.com

User avatar
timstephens24
Posts: 706
Joined: 09 Dec 2015, 22:43

Re: Forced ASS subtitles not showing

Post by timstephens24 » 11 Feb 2018, 18:48

Any update on this?

User avatar
amet
Team MrMC
Posts: 2209
Joined: 26 Oct 2015, 16:59

Re: Forced ASS subtitles not showing

Post by amet » 23 Feb 2018, 06:06

hey, you think you can upload the file again? I must have misplaced it since last time I was trying to deal with this.

User avatar
timstephens24
Posts: 706
Joined: 09 Dec 2015, 22:43

Re: Forced ASS subtitles not showing

Post by timstephens24 » 23 Feb 2018, 15:10

Ok I'll get another up and email the link in a few hours.

User avatar
timstephens24
Posts: 706
Joined: 09 Dec 2015, 22:43

Re: Forced ASS subtitles not showing

Post by timstephens24 » 23 Feb 2018, 17:39

Just sent another one. Let me know if you need anything else.

User avatar
amet
Team MrMC
Posts: 2209
Joined: 26 Oct 2015, 16:59

Re: Forced ASS subtitles not showing

Post by amet » 23 Feb 2018, 20:24

Seen it, thanks!

Afk for next few days, will check it once back.

User avatar
amet
Team MrMC
Posts: 2209
Joined: 26 Oct 2015, 16:59

Re: Forced ASS subtitles not showing

Post by amet » 02 Mar 2018, 17:22

ok so tried to reproduce this and its showing fine here, I have set the subs to "forced only" and its fine.

I suspect that your issue is somewhere in this spaghetti ... https://github.com/MrMC/mrmc/blob/maste ... r.cpp#L138

Code: Select all

 
 *          A subtitle is relevant if
  *          - it was previously selected, or
  *          - it's an external sub, or
  *          - it's a forced sub and "original stream's language" was selected, or
  *          - it's a forced sub and its language matches the audio's language, or
  *          - it's a default sub, or
  *          - its language matches the preferred subtitle's language (unequal to "original stream's language")
  
try setting audio language to "english" and see if that triggers 4th condition

User avatar
timstephens24
Posts: 706
Joined: 09 Dec 2015, 22:43

Re: Forced ASS subtitles not showing

Post by timstephens24 » 02 Mar 2018, 18:18

Ok I'll try when the power comes back. Stupid wind.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 9 guests