1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Bitstreaming Dolby with Atmos: channel mapping issue ?

Any issues that are tvOS specific
Post Reply
User avatar
loekf2
Posts: 102
Joined: 26 Nov 2015, 09:48

Bitstreaming Dolby with Atmos: channel mapping issue ?

Post by loekf2 » 08 Jan 2018, 13:38

I played the same HEVC file with Dolby audio track, incl. Atmos. Using passthrough (bitstreaming).

On the AppleTV 4K the front channel is coming out of my rear left speaker. The front and center speakers are silent,

On a Nvidia Shield all is ok. At first there was no bitstreaming at all, but looks like Kodi messes up bitstreaming for some reason. Could not check Kodi, because both Kodi and SPMC throw error 2 when you try to connect to a SMB share on my NAS. MrMC works fine.

Kodi on PC is also ok.

Could there be something with the channel mappings ? AFAIK, when doing bitstreaming you do not touch the channel mappings, that is for the receiver to do. My Onkyo receiver suggest bitstreaming audio is received, so no PCM.

(running the latest beta)

User avatar
davilla
Team MrMC
Posts: 3518
Joined: 26 Oct 2015, 17:01

Re: Bitstreaming Dolby with Atmos: channel mapping issue ?

Post by davilla » 08 Jan 2018, 16:19

Remember, HD Audio is not "bit streamed" on the AppleTV4/4K. All HD audio is decoded and passed over as multi-channel PCM.

To support HD audio passthough, we need to set a sample rate of 192kHz and only 48kHz is possible.

Apple as promised Atmos support for the AppleTV4/4K but we have not seen any changes.

Debuglog 's and a sample of the content that gives in-correct mapping please.

User avatar
loekf2
Posts: 102
Joined: 26 Nov 2015, 09:48

Re: Bitstreaming Dolby with Atmos: channel mapping issue ?

Post by loekf2 » 08 Jan 2018, 16:46

Think I found a possible cause. I had the channel layout set to 7.1 (my receiver is 7.1 capable, but I have a 5.1 speaker setup), what I usually do for Kodi & MrMC.

For this HEVC 4K movie (Fantastic Beasts) with an Atmos track the audio is ok (SL and SR do what they are supposed to do) when set to 5.1.

Not sure why for Dolby this is an issue. I see the same behaviour for a movie with a TrueHD track. Over the weekend I played a bunch of 4K movies with DTS:X and they were all fine (so with output set to 7.1 and let the receiver figure out what to do with them.. i.e. map things to 5.1).

I have logging + a short clip. I will mail you the data.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests