1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Missing Shadow Detail, nothing below 2.5% black

Any issues that are tvOS specific
cosmoxl
Posts: 1402
Joined: 12 Dec 2015, 14:16

Re: Missing Shadow Detail, nothing below 2% black

Post by cosmoxl » 21 Jan 2018, 15:16

Boris Blank wrote:
21 Jan 2018, 14:37
Managed to attach the Apple to another 4k HDR TV set, a Samsung KS7000. Exactly the same issue, the test patterns show no bars at 2% and below.

I also tried the latest TestFlight 3.4.1 dated 18th Jan, same issue.

I've not noticed anyone else reporting this problem but its there nonetheless.
Is this a dolby vision test? If so, have you seen the fix to DV that TV makers have to implement to get right?

Boris Blank
Posts: 17
Joined: 23 Dec 2017, 13:16

Re: Missing Shadow Detail, nothing below 2% black

Post by Boris Blank » 21 Jan 2018, 21:13

No, unfortunately not. Its HDR-10 test patterns :(

wesk05
Posts: 67
Joined: 20 Dec 2017, 06:20

Re: Missing Shadow Detail, nothing below 2% black

Post by wesk05 » 22 Jan 2018, 05:56

This to me looks like another tvOS problem associated with HDR processing. The upper and lower 2% of the grayscale is being clipped. In the referenced test pattern, YCbCr digit value of 81 and lower are output as 64. Similarly, everything above digit value of 922 (98%) is clipped. White clipping isn't going to be a problem because at present most HDR content have the maximum luminance of mastering display set to 4000 nits (855) or 1000 nits (723).

This clipping occurs with HDR modes and interestingly also with SDR content when an SDR output mode is selected and match dynamic range is also enabled. Clipping doesn't occur with SDR content when the match dynamic range option is disabled.

BTW, output from Infuse has totally messed up grayscale values.

Boris Blank
Posts: 17
Joined: 23 Dec 2017, 13:16

Re: Missing Shadow Detail, nothing below 2% black

Post by Boris Blank » 23 Jan 2018, 11:01

Hi wesk05,

Thanks for your input, I was thinking only myself and another fella on AVForums was seeing this.

Yes you are correct, HDR clipping at both ends of the spectrum, I must admit I'd only focussed on the bottom end black level, had at look at contrast and yes indeed, clipping above 98%.

Just checked and double checked SDR black level, (using SDR patterns in SDR mode) it's spot on for me, even when using match dynamic range and switching from HDR into SDR. As an aside, using the exact same SDR patterns from the same source and viewing them on my Nvidia Shield via SPMC, the TV settings are identical for black level, no adjustments required. Odd you are seeing differences in SDR, I checked MrMC and also SPMC on the Shield and they are at default settings - I have no doubt you are seeing it though, strange things happening somewhere thats for sure.

I also tried turning off match dynamic range, everything still good, no clipping of SDR material in SDR mode.

For Contrast in SDR, I normally click SPMC and MrMC down a click or two down to 48% so yes, maybe some clipping indeed but consistent across Shield/ATV4k and SPMC and MrMC (at least with my AV chain - Shield/ATV4k into Denon x4300 into Sony ZD9). Again, no difference when I switch off match dynamic range.

This is all just crazy! :lol:

Yes, Infuse is totally screwed up HDR-wise but they do look to be tackling it although I don't use Infuse for much if anything.

wesk05
Posts: 67
Joined: 20 Dec 2017, 06:20

Re: Missing Shadow Detail, nothing below 2% black

Post by wesk05 » 23 Jan 2018, 17:06

Try this pattern: https://mega.nz/#!IM9jGDrI!LBez44IOhski ... t9HcINYIeQ
It's the same pattern from Ryan, but stripped off the HDR SEI. I had checked with the MP4 version, will check again with the TS version.

Boris Blank
Posts: 17
Joined: 23 Dec 2017, 13:16

Re: Missing Shadow Detail, nothing below 2% black

Post by Boris Blank » 23 Jan 2018, 17:43

Yes, it was the MP4 version I've been for HDR patterns, for SDR I was using AVS HD 709, heres a link for the Black Clipping Rec 709 pattern I used - https://www.dropbox.com/s/zcgxb492096aa ... g.mp4?dl=0

Will check your upload shortly.

EDIT:

OK, checked your pattern via MrMC, its missing the 2% and below black bars and its triggering HDR mode on the the ZD9 - something still in the pattern doing this maybe? All bars showing on my non-HDR PC monitor. I'll switch the Apple to SDR mode and see what happens, back in a mo...!

Back again, switched off match dynamic range, all bars showing on your pattern. Thats interesting, so there must definately still be something in the pattern triggering the Apple into HDR mode unless range matching is set to off.

wesk05
Posts: 67
Joined: 20 Dec 2017, 06:20

Re: Missing Shadow Detail, nothing below 2% black

Post by wesk05 » 23 Jan 2018, 18:45

The pattern has been stripped off all HDR/BT.2020 related parameters. Yes, when you play it with match dynamic range, HDR mode is trigerred, but the max /min luminance is 250/0 nits (if I remember correctly). I will try a SDR reencode of the pattern and check whether it is any different.

Boris Blank
Posts: 17
Joined: 23 Dec 2017, 13:16

Re: Missing Shadow Detail, nothing below 2% black

Post by Boris Blank » 23 Jan 2018, 19:08

Hmmm, something in the pattern must still be triggering the Apple, content, specfic code or whatever (I've no idea really :? )

Thanks for your efforts, very much appreciated!

wesk05
Posts: 67
Joined: 20 Dec 2017, 06:20

Re: Missing Shadow Detail, nothing below 2% black

Post by wesk05 » 24 Jan 2018, 05:00

There is nothing wrong with the SDR test pattern. It looks like when you play 4K 10-bit HEVC non HDR content in SDR output mode with match dynamic range enabled, the actual HDMI output is BT.2020, 250/0.05nits Max/Min luminance and 250/100 MaxFALL/MaxCLL. This doesn't happen with 4K 8-bit HEVC SDR content. That is output correctly. I also noticed that when you play 1080p 10-bit HEVC content, the output is still in 8-bit color depth. Since Infuse is all messed up, I can't say for sure whether this is a tvOS or MrMC problem.

Here are two samples modified from the AVS HD 709 test pattern:
1080p 10-bit black clipping pattern: https://mega.nz/#!kQdySCxZ!BE1aKjMAFQmI ... 5hfQy4RT4g

2160p 10-bit black clipping pattern: https://mega.nz/#!lIFn1SAb!niD1g4UYeKJ7 ... Paox7DIflQ

Boris Blank
Posts: 17
Joined: 23 Dec 2017, 13:16

Re: Missing Shadow Detail, nothing below 2% black

Post by Boris Blank » 24 Jan 2018, 08:39

Ok, I think I understand, somewhere along the line its tvOS, Infuse or MrMC's mis-interpreting of what it thinks its processing thats causing it to select the incorrect mode.

Simplfying it a bit, tvOS/MrMC/Infuse are thinking "well if its 4k, HEVC and 10bit it must be HDR" - is that roughly whats going on? And of course somewhere along the line things are getting clipped as well.

Its a mess. Luckily, I doubt most folks would notice anything was wrong but it needs fixing though!
Last edited by Boris Blank on 24 Jan 2018, 15:16, edited 1 time in total.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests