Page 1 of 1

Video calibration settings not being saved

Posted: 06 Dec 2017, 14:28
by fhall1
Running an ATV4, tvOS 11.2, MrMC 3.3-0.

I notice the last 3 times I have run MrMC (starting from the tvOS home screen) that the "Video Calibration" settings do not stay where I set them between sessions. Not sure if the 11.2 tvOS update or the MrMC 3.3 update did this, but when I first start MrMC the text at the very top and bottom of the screen (Amber Skin) are cut off. If I go into the Settings, System Settings, Video Calibration I can adjust the screen size so everything is perfect (essentially removing the overscan I guess). The setting stays for the current session of MrMC, but if I back out to the ATV4 home screen then go back into MrMC, the overscan is back and I have to go into the calibration settings and set it up all over again. I don't see any way to hit a "save settings" after I calibrate it, so I assume it should "stick" - and it used to for all previous versions up until now.

Any suggestions?

Re: Video calibration settings not being saved

Posted: 06 Dec 2017, 14:49
by davilla
ok, might be related to display rate tracking that was added to get the display refresh rate. This value propagates to display rez which is used for calibration lookups.

Just found out that the AppleTV4K has rock solid display rate tracking while the AppleTV4 wanders. Testing in Testflight v3.3.1 and should be fixed in next release.

Re: Video calibration settings not being saved

Posted: 06 Dec 2017, 16:37
by fhall1
Great news - thanks!

Re: Video calibration settings not being saved

Posted: 08 Dec 2017, 07:48
by Buadhai
Same here.

ATV3
TVOS 11.2
MrMC 3.3-0

Re: Video calibration settings not being saved

Posted: 08 Dec 2017, 12:05
by amet
Atv3? Atv4 maybe? :)

Re: Video calibration settings not being saved

Posted: 08 Dec 2017, 12:53
by davilla
Need someone with this issue to join testflight for v3.3.1 and see if the issue is fixed.

viewtopic.php?f=10&t=1468