1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

tvOS 11 audio changes?

Any issues that are tvOS specific
Post Reply
cosmoxl
Posts: 644
Joined: 12 Dec 2015, 14:16

tvOS 11 audio changes?

Post by cosmoxl » 11 Aug 2017, 15:10

I'm testing tvOS 11 and have experienced what I think are some system audio changes with which MrMC doesn't work properly.

I know it's not super urgent that this gets fixed but I figure you might like to get a jump on it for when tvOS 11 is released.

1) Passthrough which has worked in the past now gives static for me.

2) https://gist.github.com/anonymous/74c47 ... 610f9e270f See log here. Audio problems first got my attention when audio from a video wouldn't play. The track is 5.0 - left, center, right, surround, no LFE. You'll see an error in the log saying that's not supported.

3) If I switch to 2.0 or 2.1 output, the audio from that 5.0 track plays. However, there are some weird quirks with the way other audio is handled. I'm sure once you start looking at this you'll see.

cosmoxl
Posts: 644
Joined: 12 Dec 2015, 14:16

Re: tvOS 11 audio changes?

Post by cosmoxl » 11 Aug 2017, 15:34

For now a workaround seems to be to set to "fixed" audio, not best fit or optimized. 7.1 and "fixed" and the audio from the problematic track plays after a reboot of the system.

And in case you're wondering, I'd certainly rebooted prior to changing to fixed. It wasn't the reboot that fixed (no pun intended) it. ;)

cosmoxl
Posts: 644
Joined: 12 Dec 2015, 14:16

Re: tvOS 11 audio changes?

Post by cosmoxl » 11 Aug 2017, 23:19

Looks like audio doesn't work right after waking the ATV4 up from sleep when MrMC is set to fixed and ATV4 settings are at "best quality available". A reboot is required to get it working again reliably.

But, setting ATV4 to DD 5.1 and MrMC to fixed 5.1 seems to work reliably.

User avatar
davilla
Team MrMC
Posts: 2051
Joined: 26 Oct 2015, 17:01

Re: tvOS 11 audio changes?

Post by davilla » 13 Aug 2017, 13:46

interesting, will check when we roll into iOS/tvOS 11.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest