1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Testing MrMC 3.8.0 - [Invites Closed]

User avatar
amet
Team MrMC
Posts: 2416
Joined: 26 Oct 2015, 16:59

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by amet » 08 Feb 2019, 13:23

Montoya wrote:
08 Feb 2019, 09:09
davilla wrote:
08 Feb 2019, 03:22
3.8.0 (190208.208)
core: no input if splash is up
skin: sync opacity/ariana
The splash screen seems not to be tested with multiple MrMC profiles.

Can't use MrMC profile switching anymore, because when loading a MrMC profile from log-in screen, it's trying to show the 5 seconds splash again, but hangs directly. The OSD with scrubber stays active, but there is no way out of it, to get to the menu's or stop the splash movie clip.

Reverting back to previous Testflight.
Btw, in 3.8.0 (190203.1722) the splash screen never showed up, when multiple MrMC profiles are in use.

PS: Thanks for adding "Emby" green in Opacity :D
I cant reproduce this, anyone else? tested with 3 profiles and it shows video splash and home screen after it

User avatar
Montoya
Posts: 272
Joined: 27 Sep 2017, 22:46

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by Montoya » 08 Feb 2019, 14:23

amet wrote:
08 Feb 2019, 13:23
Montoya wrote:
08 Feb 2019, 09:09
davilla wrote:
08 Feb 2019, 03:22
3.8.0 (190208.208)
core: no input if splash is up
skin: sync opacity/ariana
The splash screen seems not to be tested with multiple MrMC profiles.

Can't use MrMC profile switching anymore, because when loading a MrMC profile from log-in screen, it's trying to show the 5 seconds splash again, but hangs directly. The OSD with scrubber stays active, but there is no way out of it, to get to the menu's or stop the splash movie clip.

Reverting back to previous Testflight.
Btw, in 3.8.0 (190203.1722) the splash screen never showed up, when multiple MrMC profiles are in use.

PS: Thanks for adding "Emby" green in Opacity :D
I cant reproduce this, anyone else? tested with 3 profiles and it shows video splash and home screen after it
Here is a video clip when I try to switch profiles:
https://streamable.com/pvrbu

The scrubber you see moving, that 's me trying to go to the end of the splash clip.
In that screen, MrMC isn't able to get out of it. Maybe this is causing this:

Code: Select all

core: no input if splash is up
MrMC is setup in my system to always load the Master profile. It gets there by first showing splash screen.
Apple TV 4K 64GB tvOS 12.1.2, Win10 Pro x64 1809 build17763.292
DVBLink server 6.0.0 build14499, DVBLink TVSource 6.0.0 build14061, DVBLink for IPTV build 13107
TVMosaic server build 17051, Emby server build 4.1.0.1 beta

maglione66
Posts: 11
Joined: 08 Feb 2019, 14:53

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by maglione66 » 08 Feb 2019, 15:02

Hi, the last version 3.8-0 Feb 8 1019, lost the options for passthrough DTS HD, Dolby TrueHD, the previous version 3.7 work Ok, this don't work HD audio. Nvidia Shield TV. Thanks!

Itzme1234
Posts: 310
Joined: 09 Dec 2015, 22:02

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by Itzme1234 » 08 Feb 2019, 17:48

If I watch live tv (Ariana, HDHomeRun, guide view) and use the down button to channel surf for a couple channels, and then I hit menu I exit to the bottom of an empty grid. If I select a single channel and watch live TV and then hit menu, I exit out back to where I was in the guide, as expected.

I was able to replicate this several times, but not every time.

Also, is the push and hold context menu in Ariana/Plex service new?

User avatar
Ted377
Posts: 223
Joined: 24 Jul 2016, 12:36
Location: Germany

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by Ted377 » 08 Feb 2019, 23:30

Does this only affect users with different profiles?
What should I set to test/reproduce the issue?
SET-TOP-BOX: Apple TV 4
FW: tvOS 12.1.2
Front-End: MrMC 3.7.1
SET-TOP-BOX: Apple TV 4K
FW: tvOS 12.2
Front-End: mrmc 3.8.0 (190217.2127)
NAS: QNAP TS-231P
Back-End: TVHeadend/PLEX
TUNER: XORO SAT>IP Server 8100
SATELLITE DISH: SELFSAT H22DQ+

User avatar
Ted377
Posts: 223
Joined: 24 Jul 2016, 12:36
Location: Germany

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by Ted377 » 09 Feb 2019, 01:58

The only thing that strikes me when I start is that the MrMC logo flashes very briefly and then the splash screen is displayed.
SET-TOP-BOX: Apple TV 4
FW: tvOS 12.1.2
Front-End: MrMC 3.7.1
SET-TOP-BOX: Apple TV 4K
FW: tvOS 12.2
Front-End: mrmc 3.8.0 (190217.2127)
NAS: QNAP TS-231P
Back-End: TVHeadend/PLEX
TUNER: XORO SAT>IP Server 8100
SATELLITE DISH: SELFSAT H22DQ+

User avatar
logan_x50
Posts: 96
Joined: 07 May 2016, 06:54

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by logan_x50 » 09 Feb 2019, 09:23

Montoya wrote:
08 Feb 2019, 14:23
amet wrote:
08 Feb 2019, 13:23
Montoya wrote:
08 Feb 2019, 09:09

The splash screen seems not to be tested with multiple MrMC profiles.

Can't use MrMC profile switching anymore, because when loading a MrMC profile from log-in screen, it's trying to show the 5 seconds splash again, but hangs directly. The OSD with scrubber stays active, but there is no way out of it, to get to the menu's or stop the splash movie clip.

Reverting back to previous Testflight.
Btw, in 3.8.0 (190203.1722) the splash screen never showed up, when multiple MrMC profiles are in use.

PS: Thanks for adding "Emby" green in Opacity :D
I cant reproduce this, anyone else? tested with 3 profiles and it shows video splash and home screen after it
Here is a video clip when I try to switch profiles:
https://streamable.com/pvrbu

The scrubber you see moving, that 's me trying to go to the end of the splash clip.
In that screen, MrMC isn't able to get out of it. Maybe this is causing this:

Code: Select all

core: no input if splash is up
MrMC is setup in my system to always load the Master profile. It gets there by first showing splash screen.
I have the same behaviour. I have 2 profiles and MrMC is set so that on start-up one of the user profiles needs to be selected. If I select the (renamed) master profile it will hang at the intro movie and I will need to close mrmc with the tv button on the remote and force close swipe. However, the non master profile I've set up will play the intro movie just fine and mrmc will launch the homepage

User avatar
davilla
Team MrMC
Posts: 3777
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by davilla » 09 Feb 2019, 21:57

3.8.0 (190209.2032)
core: add video splash detection, disable res switching if running
core: run splash video from application, not from the skin
FIX: AC3 is not always 32ms
ADD: [amc;debug] log supported mime types
CHG: [droid] come back to mrmc after a youtube play
FIX: [droid] force https for youtube channel trailers
CHG: [droid] audio refactor
FIXUP: ActiveAE: Differentiate DTS-HD-MA and DTS-HD-HR
FIXUP: [cmake] add DolbyFrameParser & MemoryBitstream
emby: fix external subtitles
FIX: folders on home

User avatar
Montoya
Posts: 272
Joined: 27 Sep 2017, 22:46

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by Montoya » 10 Feb 2019, 00:48

davilla wrote:
09 Feb 2019, 21:57
core: add video splash detection, disable res switching if running
core: run splash video from application, not from the skin
No problems anymore in my multi profile MrMC setup :D
davilla wrote:
09 Feb 2019, 21:57
FIX: AC3 is not always 32ms
I still notice MrMC Volume levels are off, so now I did some peak sound level measurements in dB with iOS "dB meter", a digital dB meter app which records average and peak sound levels.

Live TV AC3 channel vs Recording play of that same channel in MrMC vs play of that same recording in Infuse:
MrMC is approx. 6dB down in peak level when playing the recording, compared to Live TV channel play or Infuse.

Local content, intro clip 20th Century Fox Bohemian Rhapsody (eAC3 or DD+)
MrMC is approx. 9dB down in peak level compared to Infuse during that intro clip. Infuse sounds more spatial and vibrant.

I double checked if audio settings in MrMC during play, used different settings for "Volume & Volume amplification", but both were set at 0.0dB.

The dB difference I find is quit big. Any advise what to check for sound settings are welcome. My receiver is fed with Toslink from my HDMI 6x2 Matrix switch (no HDMI receiver here yet), so my Apple TV sound settings are set to DD5.1. But I doubt that has something to do with MrMC being down in peak sound level, because Infuse plays them at normal level, when I compare sound level of Live TV channel vs recording of that same channel in Infuse.
davilla wrote:
09 Feb 2019, 21:57
emby: fix external subtitles
Excellent, they work flawlessly now :D
davilla wrote:
09 Feb 2019, 21:57
FIX: folders on home
Is that fix for Emby ?
Apple TV 4K 64GB tvOS 12.1.2, Win10 Pro x64 1809 build17763.292
DVBLink server 6.0.0 build14499, DVBLink TVSource 6.0.0 build14061, DVBLink for IPTV build 13107
TVMosaic server build 17051, Emby server build 4.1.0.1 beta

jpalenz77
Posts: 42
Joined: 03 Apr 2018, 13:09

Re: Testing MrMC 3.8.0 - [Invites Closed]

Post by jpalenz77 » 10 Feb 2019, 01:34

This new update broke plex server selection on homescreen.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests