1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Testing MrMC 3.7.0 - [Closed]

User avatar
amet
Team MrMC
Posts: 2035
Joined: 26 Oct 2015, 16:59

Re: Testing MrMC 3.7.0

Post by amet » 08 Jul 2018, 17:17

jpalenz77 wrote:
08 Jul 2018, 17:13
Hehe, yeah I know, just wanted to put some “pressure” on him. Hehehehe

azriel84 wrote:
08 Jul 2018, 17:11
jpalenz77 wrote:
08 Jul 2018, 17:03
Speaking of AVF, are you guys working on making ambilight compatible with it?

Thank you
+1, I think davilla said will look into it at some point :D
pressure might actually have an opposite effect :D

jpalenz77
Posts: 27
Joined: 03 Apr 2018, 13:09

Re: Testing MrMC 3.7.0

Post by jpalenz77 » 08 Jul 2018, 17:22

I know, was just kidding. Of course I can wait, I know there are other more important issues on your list.

Keep your awesome work up!
amet wrote:
08 Jul 2018, 17:17
jpalenz77 wrote:
08 Jul 2018, 17:13
Hehe, yeah I know, just wanted to put some “pressure” on him. Hehehehe

azriel84 wrote:
08 Jul 2018, 17:11


+1, I think davilla said will look into it at some point :D
pressure might actually have an opposite effect :D

User avatar
davilla
Team MrMC
Posts: 3425
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.7.0

Post by davilla » 08 Jul 2018, 17:28

(180708.1602 @20180708-ea895b5)
FIX: iOS needs to use maxChannels, some devices only have one
FIX: CSlideEffect needs to use MathUtils::round_int or we can get fractional pixels
ADD: CApplication method for when skin is changing
FIX: hang on auto skin switch.
FIX: [amc] debug on-demand
FIX: [amc] multiple frames per packet was broken

User avatar
davilla
Team MrMC
Posts: 3425
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.7.0

Post by davilla » 08 Jul 2018, 17:32

azriel84 wrote:
08 Jul 2018, 16:59
tried vtb with all kind of files, SD to 4K HDR (just to check lipsync despite the awful picture quality) and it didn't have any lipsync issues whatsoever with my MrMC and AVR settings as I have them for a long time now. The problem is that now even with h265/HDR files where avf is the only way to go, I have this slight issue which didn't happen before, I don't know if any changes were made in the latest build that affected lipsync with avf. I would like to use the recommended settings but tbh, I prefer avf for every situation, it gives me perfect picture quality in any situation, at least for my preferences, without having to change picture settings in my TV according to the source material and which codec is being used (vtb is a lot more bright by default than avf for example and TV).

Is there any specific a/v setting I would like to inform you with that might cause that issue?
cosmoxl is the resident judge of correct a/v sync.

again, What is your current a/v offset in MrMC ?

cosmoxl
Posts: 1312
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.7.0

Post by cosmoxl » 08 Jul 2018, 18:14

davilla wrote:
08 Jul 2018, 17:32
azriel84 wrote:
08 Jul 2018, 16:59
tried vtb with all kind of files, SD to 4K HDR (just to check lipsync despite the awful picture quality) and it didn't have any lipsync issues whatsoever with my MrMC and AVR settings as I have them for a long time now. The problem is that now even with h265/HDR files where avf is the only way to go, I have this slight issue which didn't happen before, I don't know if any changes were made in the latest build that affected lipsync with avf. I would like to use the recommended settings but tbh, I prefer avf for every situation, it gives me perfect picture quality in any situation, at least for my preferences, without having to change picture settings in my TV according to the source material and which codec is being used (vtb is a lot more bright by default than avf for example and TV).

Is there any specific a/v setting I would like to inform you with that might cause that issue?
cosmoxl is the resident judge of correct a/v sync.

again, What is your current a/v offset in MrMC ?
I haven't watched a lot of stuff in MrMc lately to have a say on a/v sync. I'm wondering if tvOS 12 is in use?

User avatar
amet
Team MrMC
Posts: 2035
Joined: 26 Oct 2015, 16:59

Re: Testing MrMC 3.7.0

Post by amet » 08 Jul 2018, 20:11

amet wrote:
08 Jul 2018, 05:31
ersan191 wrote:
08 Jul 2018, 04:33
jrcorwin wrote:
08 Jul 2018, 03:22
So I’ve been experimenting with just using stock MrMc (Test Flight version) to access my Plex server, instead of the Plex extension. Is it supposed to give me the option of choosing a version if I have more than one of a film?

I’ll use Avatar as an example. I have both a 1080p and a 4K HDR version and they are grouped (rather than split) on my Plex server. MrMc doesn’t prompt me to choose a version to play. Should it be?
I don't believe any Plex clients prompt either - I experimented a long time ago with having 1080p and 4K versions of the same movie and it would always play the 4K version despite the Plex website saying it should pick the "appropriate version".
It should ask, it did before .... will check
it works here from a MrMC plex integration, granted I only have few movies with multiple resolutions but it works as intended ...

Image

azriel84
Posts: 20
Joined: 03 Apr 2018, 10:44

Re: Testing MrMC 3.7.0

Post by azriel84 » 08 Jul 2018, 21:43

cosmoxl wrote:
08 Jul 2018, 18:14
davilla wrote:
08 Jul 2018, 17:32
azriel84 wrote:
08 Jul 2018, 16:59
tried vtb with all kind of files, SD to 4K HDR (just to check lipsync despite the awful picture quality) and it didn't have any lipsync issues whatsoever with my MrMC and AVR settings as I have them for a long time now. The problem is that now even with h265/HDR files where avf is the only way to go, I have this slight issue which didn't happen before, I don't know if any changes were made in the latest build that affected lipsync with avf. I would like to use the recommended settings but tbh, I prefer avf for every situation, it gives me perfect picture quality in any situation, at least for my preferences, without having to change picture settings in my TV according to the source material and which codec is being used (vtb is a lot more bright by default than avf for example and TV).

Is there any specific a/v setting I would like to inform you with that might cause that issue?
cosmoxl is the resident judge of correct a/v sync.

again, What is your current a/v offset in MrMC ?
I haven't watched a lot of stuff in MrMC lately to have a say on a/v sync. I'm wondering if tvOS 12 is in use?
Had the same issue in tvOS 11.4 and tvOS 12 public beta 2 that I installed afterwards just in case. Anyhow, the offset on the AVR is 0ms with its lipsync function enabled (didn't have any impact either enabled or disabled anyway, it's on by default) and I set the MrMC audio offset to 100ms for every kind of video file, using AVF only with the same settings I've been using in MrMC since the beginning, no changes at all. Perfect lipsync now. Have in mind, that when I disabled frame rate switching in ATV settings I didn't have any issues whatsoever, but that's not an optimal solution.

cosmoxl
Posts: 1312
Joined: 12 Dec 2015, 14:16

Re: Testing MrMC 3.7.0

Post by cosmoxl » 08 Jul 2018, 22:13

azriel84 wrote:
08 Jul 2018, 21:43
cosmoxl wrote:
08 Jul 2018, 18:14
davilla wrote:
08 Jul 2018, 17:32


cosmoxl is the resident judge of correct a/v sync.

again, What is your current a/v offset in MrMC ?
I haven't watched a lot of stuff in MrMC lately to have a say on a/v sync. I'm wondering if tvOS 12 is in use?
Had the same issue in tvOS 11.4 and tvOS 12 public beta 2 that I installed afterwards just in case. Anyhow, the offset on the AVR is 0ms with its lipsync function enabled (didn't have any impact either enabled or disabled anyway, it's on by default) and I set the MrMC audio offset to 100ms for every kind of video file, using AVF only with the same settings I've been using in MrMC since the beginning, no changes at all. Perfect lipsync now. Have in mind, that when I disabled frame rate switching in ATV settings I didn't have any issues whatsoever, but that's not an optimal solution.
I don't see the same offset from every video so I manually adjust if I need to. I also use AVF for everything. It seems a lot better than it used to be for h264.

User avatar
Montoya
Posts: 136
Joined: 27 Sep 2017, 22:46

Re: Testing MrMC 3.7.0

Post by Montoya » 08 Jul 2018, 22:49

Feedback tvOS 11.4 Apple TV 4K:

PVR Live TV and recordings (Opacity):
Skipping FW/BW with Logitech Harmony Elite doesn’t follow set skip steps time. For example, skip step time FW is set to +30s only in settings, but with one press on Logitech Harmony Elite, MrMC skips FW directly for 60s. (In settings I use the default standard delay).

Same applies for skipping BW, that double amount of set skip step time is done with only one press on Logitech Elite.

User avatar
timstephens24
Posts: 622
Joined: 09 Dec 2015, 22:43

Re: Testing MrMC 3.7.0

Post by timstephens24 » 09 Jul 2018, 00:15

azriel84 wrote:
08 Jul 2018, 21:43
Have in mind, that when I disabled frame rate switching in ATV settings I didn't have any issues whatsoever, but that's not an optimal solution.
Since frame rate switching on the ATV I've had a 200ms delay on my Denon AVR, but it's global for every app, not just MrMC.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests