1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

Testing MrMC 3.3.1

User avatar
davilla
Team MrMC
Posts: 3150
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.3.1

Post by davilla » 13 Dec 2017, 20:15

timstephens24 wrote:
13 Dec 2017, 20:12
Newest TestFlight:

Unchecked "Use limited color range (16-235)" = reference 16 is black where it should be
so good for you ?

User avatar
timstephens24
Posts: 547
Joined: 09 Dec 2015, 22:43

Re: Testing MrMC 3.3.1

Post by timstephens24 » 13 Dec 2017, 20:17

Yup, it's good so far. I'll watch my actual recordings on it a little later.

User avatar
davilla
Team MrMC
Posts: 3150
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.3.1

Post by davilla » 13 Dec 2017, 22:12

(20171213-8e9dacb)
add setting to disable default limited to full rescaling of video content

@three6zerocool, this setting is for you. settings -> video -> acceleration -> "Disable limited to full video rescaling"

This with limited disabled should give the same results as TestFlight build (171207.1831)

mrs4t4n
Posts: 27
Joined: 21 Nov 2017, 14:05

Re: Testing MrMC 3.3.1

Post by mrs4t4n » 14 Dec 2017, 08:17

Same here.
With the last build, if limited is checked, blacks are washed. When uncheckd everything was right...

three6zerocool
Posts: 56
Joined: 23 Jan 2016, 10:24

Re: Testing MrMC 3.3.1

Post by three6zerocool » 14 Dec 2017, 10:03

(Grin). Thanks for that setting!.
Yes, it does indeed display HD test patterns as per that earlier build.

However..... (Oh oh, the developer says)

When I play SDR Recorded content from my PVR, it is still completely washed out with gray bars on letterboxes or 4x3 content instead of black.

If I watch the same content on the actual Mediacenter PC, it plays as it should with nice blacks.
(Damn, damn and Triple damn even.) (Snagglepuss??)

I wonder if it is due to the AppleTV4k interpreting the range incorrectly of these Mediaportal originated TS recordings that my PVR creates.?

Is kinda interesting, as I have quite a collection of these recordings, including both SD and HD content,
Watching live tv from both SD content from set top box, and SD content from DVB-T source has blown up black levels, but Movies and TV shows collections thru Plex service look good.

Earlier TestFlight builds do not exhibit the above behavior, so am guessing recent changes are the result of what I am experiencing.

three6zerocool
Posts: 56
Joined: 23 Jan 2016, 10:24

Re: Testing MrMC 3.3.1

Post by three6zerocool » 14 Dec 2017, 11:35

Okay... Something interesting.

I discovered that the raised black levels I see with recorded and live SDR content from Mediaportal is fixed, if I change Deinterlace setting in OSD/Settings/Video from 'Auto' to 'Off'

Seems kinda weird to have to do that change, but setting of On, or Auto results in dramatically raised black levels, and visibly gray bars on 4x3 or letterboxed content sourced from MediaPortal PVR.

With Deinterlace setting off, all seems fine.
It is worth noting that this particular PVR source is 'interlaced' 1080i' for these recordings in my country.

User avatar
davilla
Team MrMC
Posts: 3150
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.3.1

Post by davilla » 14 Dec 2017, 14:19

three6zerocool wrote:
14 Dec 2017, 11:35
Okay... Something interesting.

I discovered that the raised black levels I see with recorded and live SDR content from Mediaportal is fixed, if I change Deinterlace setting in OSD/Settings/Video from 'Auto' to 'Off'

Seems kinda weird to have to do that change, but setting of On, or Auto results in dramatically raised black levels, and visibly gray bars on 4x3 or letterboxed content sourced from MediaPortal PVR.

With Deinterlace setting off, all seems fine.
It is worth noting that this particular PVR source is 'interlaced' 1080i' for these recordings in my country.
Interesting, that means that particular deinterlacer (default) is messing with color ranges, what about the others. Are they doing the same thing ?

Your particular setup seem different than the 90 percentile of everyone else. But it has me interested. We will continue to look into the whys but v3.3.1 has to go out or it will stall getting v3.4.0 out before apple app submission shuts down for holiday on the 23rd.

As v3.3.1 seems ok now. We will be moving into release for it.

three6zerocool
Posts: 56
Joined: 23 Jan 2016, 10:24

Re: Testing MrMC 3.3.1

Post by three6zerocool » 15 Dec 2017, 02:18

Yeah, from what I can tell.... The levels are noticeably raised using the deinterlacing settings, but from memory by differing amounts depending on which is used. I would need to test that tho.

Switching off Deinterlacing completely fixes the issue for me, which considering the source is Pal 1080i in my country for that particular source in Mediaportal.... I guess that makes sense.

What I notice, is that when playback begins with Deinterlace on Auto, and Deinterlace type on default... The levels are fine... Then about a second or so later, they jump up.

If I disable deinterlacing completely, problem is fixed with that particular content. (Recordings and LiveTV via that Mediaportal source)

Heh heh heh.. 90 percentile eh.

Or........ have you considered that I am amongst the 10% of users who have a correctly calibrated AV system. ie. When one spends an inane amount of time calibrating displays with colorimeters and appropriate software, that for the most part exceed the costs of the TV your watching it on..... Then yes, I am I guess, guilty of not being in the 90 percentile.

As Maxwell Smart... secret agent 86 of Control would say....'aand loving it'

(Grin) maybe as I live near the bottom of the planet, the video signal is degrading thru cosmic radiation. (Tho I suspect a more elementary theory)

User avatar
davilla
Team MrMC
Posts: 3150
Joined: 26 Oct 2015, 17:01

Re: Testing MrMC 3.3.1

Post by davilla » 15 Dec 2017, 21:53

The release of 3.3.1 closes this testflight series. A new testflight series will start up in a few days.

wrxtasy
Posts: 8
Joined: 11 Dec 2017, 03:04

Re: Testing MrMC 3.3.1

Post by wrxtasy » 19 Dec 2017, 08:33

@davilla

Forwarding this from the Kodi Forum...not sure if it is v3.3.1 I will get additional info..

From @wesk05
Going back to ATV4K HDR10 metadata, I rechecked again today and I can positively say that the HDR10 metadata that is output doesn't match the original source. I tried 4 clips with different mastering display luminance, ATV4K sets the mastering display luminance to max:1000 nits and min: 0.005 nits for all the clips. It even changes the mastering display primaries from DCI-P3 to BT.2020. In short, ATV4K simply ignores the HEVC SEI metadata and replaces it with its own static HDR10 metadata. I am not sure how to test whether this is isolated to MrMC or a general ATV4K issue. I do have to say that I am not seeing this issue with Netflix or Amazon Prime HDR playback.
https://forum.kodi.tv/showthread.php?ti ... pid2680650

Locked

Who is online

Users browsing this forum: Baidu [Spider], davilla and 6 guests